Ask Your Question
0

Unable to locate package ros-kinetic-osg-interactive-markers

asked 2019-03-21 18:17:01 -0600

chyphen gravatar image

updated 2019-03-21 22:29:56 -0600

jayess gravatar image

I am trying to install uwsim with ROS Kinetic, which requires ros-kinetic-osg-interactive-markers. According to https://discourse.ros.org/t/new-packa... , it has been included in Kinetic as of 2017-02-17. However, it is not shown in "rospack list" on my laptop running uBuntue 16.04 and ros kinetic. "sudo apt-get update" doen't help either. Any suggestion how to fix the problem?

cc@G751JY:~/catkin_ws$ sudo apt-get install ros-kinetic-osg-interactive-markers
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-kinetic-osg-interactive-markers

Thanks. CC

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-22 05:27:46 -0600

gvdhoorn gravatar image

As you can see here, that package is definitely available on Ubuntu Xenial amd64 for ROS Kinetic.

The issue would seem to be on your side.

Can you install any ROS package? What is the output of cat /etc/apt/sources.list.d/ros-latest.list?

edit flag offensive delete link more

Comments

It is odd that ros-latest.list shows trusty while I have ubuntu 16.04 xenial. Reinstall ros-kinetic on xenial solved the problem. Thanks. CC

chyphen gravatar imagechyphen ( 2019-03-23 12:35:29 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-21 18:17:01 -0600

Seen: 101 times

Last updated: Mar 21 '19