Ask Your Question
0

WSL ROS master cannot subscribe client topics

asked 2019-03-14 12:11:07 -0500

tburger gravatar image

Hello everybody,

Problem: My WSL ROS master cannot subscribe client topics. Every topic is listed in "rostopic list" and "rostopic info" shows the right subcribers and publisher. On WSL i can echo my client topics but the Callback function from my WSL node gets never triggered.

Setup: I want to use a WSL machine as a ROS master and a Raspberry Pi as a ROS client. The Pi creates a WLAN connection and the WSL connects to it through a WLAN-stick. My WSL can create a ssh access to my Pi.

Windows 10 - WSL

  • Name:DESKTOP
  • Ubuntu 18.04.1
  • ROS melodic 1.14.3
  • Wifi0 IP 10.0.0.2

Raspberry Pi 3b+

  • Name: piRobot
  • Raspbian Stretch
  • ROS kinetic
  • Wlan0 10.0.0.1

Config WSL in bashrc: "export ROS_MASTER_URI=http://10.0.0.2:11311" and "export ROS_IP=10.0.0.2" Config WSL in/etc/hosts: "10.0.0.1 piRobot" and "10.0.0.2 DESKTOP"

Config Pi in bashrc: "export ROS_MASTER_URI=http://10.0.0.2:11311" and "export ROS_IP=10.0.0.1" Config Pi in/etc/hosts: "10.0.0.1 piRobot" and "10.0.0.2 DESKTOP"

Pi uses the roscore from WSL: WORKS

Pi subscribes Pi topics: WORKS

Pi subscribes WSL topics: WORKS

WSL subscribes WSL topics: WORKS

WSL subscribes Pi topics: FAIL

WSL echo Pi topics: WORKS

I used the tutorial listener and talker nodes.

Thanks for the help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-08-06 10:48:00 -0500

I exactly the same problem. I used the tutorial that you did and I copied the same code to 2 other machines where it works as expected. I have gone through all of the network testing that ROS suggests ROS Networking Setup and they all pass. The subscriber works with a publisher on wsl but not with the publisher on another system. Subscribers on other systems do get the wsl publisher messages.

So if you have found a solution, I would really appreciate hearing it.

edit flag offensive delete link more

Comments

Hello,

I could not fixed this problem. I have not tried it with the Windows Update 1903. With every Windows update they are improving the WSL, maybe try it with 1903 or the new coming update 1908.

Have a nice day!

tburger gravatar imagetburger ( 2019-08-07 05:22:45 -0500 )edit

Tried with 1903 and did an apt-get update, still no joy. I just wish I could find out where the messages are going. They are being sent and recieved by other machines. I just don't know if the network stack is throwing them away or if the callback is not getting invoked. Thanks for your feedback.

starnovice gravatar imagestarnovice ( 2019-08-07 15:54:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2019-03-14 12:09:01 -0500

Seen: 64 times

Last updated: Mar 14