Ask Your Question
0

rosserial packages not available in ros

asked 2019-03-11 07:40:55 -0500

parthchhabra gravatar image

Hi All,

I am working on ROS Melodic. On running the command: rosrun rosserial_python serial_node.py /dev/ttyACM0. I'm getting an error which says No module named 'SerialClient'

Error Output

Traceback (most recent call last): File "/opt/ros/melodic/lib/rosserial_python/serial_node.py", line 39, in <module> from rosserial_python import SerialClient, RosSerialServer File "/opt/ros/melodic/lib/python2.7/dist-packages/rosserial_python/__init__.py", line 1, in <module> from SerialClient import * ModuleNotFoundError: No module named 'SerialClient'

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-02-25 04:45:52 -0500

Shazam gravatar image

Hi,

I also struggled with the same question. You hopefully have solved the problem but for other users who find themselves in the same struggle, I want to give the solution.

For me, the problem was both Python 2.7 and Python 3.6 on the same system and things got mixed up. Because of it, when I ran 'rosrun', there were many packages missing exactly like 'SerialClient'. What solved my problem is using a virtual environment using PyCharm. I have made my environment based on Python 2.7 and it works perfectly fine. And at last, I'm able to receive data from my sensor.

Took me quite a while to figure out the problem but hope it helps someone!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-11 07:40:55 -0500

Seen: 173 times

Last updated: Mar 11 '19