Ask Your Question
0

Roslisp_Repl can't find package that is installed

asked 2019-03-06 08:00:19 -0500

mgao gravatar image

I am trying to follow this tutorial:

http://cram-system.org/tutorials/inte...

I have installed ros-kinetic-roslisp-utilities, but when I call roslisp_repl and type (roslisp-utilities:startup-ros), I get the following:

Package ROSLISP-UTILITIES does not exist.

  Line: 1, Column: 29, File-Position: 29

  Stream: #<SB-IMPL::STRING-INPUT-STREAM {10052457E3}>
   [Condition of type SB-INT:SIMPLE-READER-PACKAGE-ERROR]

Restarts:
 0: [RETRY] Retry SLIME REPL evaluation request.
 1: [*ABORT] Return to SLIME's top level.
 2: [ABORT] abort thread (#<THREAD "new-repl-thread" RUNNING {10053A5DD3}>)

I tried installing roslisp-common from source too, but same result. rospack list lists roslisp_utilities under the directory that it is installed in, so I assume that the package itself is installed just fine. But why can't roslisp-repl find it?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-06 08:30:37 -0500

gaya gravatar image

Hi,

You need to first load the package before you can use it in a function call:

(ros-load:load-system "roslisp_utilities" :roslisp-utilities)

This is explained in the following tutorial:

http://cram-system.org/tutorials/begi...

Please note that the intermediate tutorials require more in-depth understanding of CRAM. Additionally, the tutorial that you picked is tagged with version v0.6.0, whereas the current version on the master branch is v0.7.0, so some parts of the tutorial might be outdated and might not work.

HTH, Gaya

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-06 08:00:19 -0500

Seen: 47 times

Last updated: Mar 06 '19