Ask Your Question
1

ERROR: Unable to communicate with master!

asked 2012-04-12 17:45:53 -0500

njavia66 gravatar image

Hello,

My team and I have successfully went through this tutorial:

        http://www.ros.org/wiki/Robots/TurtleBot/Network%20Setup

Everything worked fine. We uploaded the follower demo and used keyboard to move turtlebot around.

Then we decided to get fancy and ping another 2 computers to the netbook on turtlebot. It actually worked! We actually ran the follower demo successfully on all 3 computers one after the other and then one of use used the keyboard teleop and it worked as well.

Unfortunately, the success was short-lived. Soon after our third member left. We tried to access the netbook from our laptops and we kept getting an error when we just tried to 'sudo service turtlebot stop':

    ERROR: Unable to communicate with master!

We checked our setting over 5 times and saw that everything from ROS_HOSTNAME and ROS_MASTER_URI was set EXACTLY like the tutorials and nothing was wrong but we kept getting the same error over and over. (Keeep in mind it ran without any issues for about the last 8-10 times we uploaded it something.)

If anyone could point us in the right debugging direction that would be great! We have googled and searched the answers.ros.org forum and we found nothing.

Any help would be GREATLY appreciated!

Thank you

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2012-04-13 01:48:42 -0500

Lorenz gravatar image

Just to be sure: was roscore running? Did rostopic list or something like that work on the netbook?

edit flag offensive delete link more

Comments

Yup it looks like roscore is not running. Either that or it's not running on the computer you're trying to set the ROS_MASTER_URI to.

Gonçalo Cabrita gravatar imageGonçalo Cabrita ( 2012-04-13 02:12:22 -0500 )edit

Well we actually did the roscore and tried to see if that worked. When we ran 'rostopic list' without using roscore it listed out a lot multiple things. Once we roscored and tried to 'rostopic list' it listed out only 2 things and still the issue was not fixed. What else can we do?

njavia66 gravatar imagenjavia66 ( 2012-04-14 11:08:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-04-12 17:45:53 -0500

Seen: 1,376 times

Last updated: Apr 13 '12