ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Solved: Problems defining large custom messages

asked 2019-02-19 06:38:52 -0500

MarcelKr gravatar image

updated 2019-02-20 02:58:18 -0500

Hey there,

I have a problem with a ROS_Node and large custom Messages. My Node shloud be capable of Publishing two ROS_Messages. These two custom Messages consist of several other custom messages to generate a deeper structur.

Example:

add_message_files(
   FILES
   A.msg
   B.msg
   C.msg
   D.msg
   ....
   MasterA.msg
   MasterB.msg
 )

The message Master.msg is dependend to A,B,C,D..... and the MasterB consits of three floats and D. When I build the project no error is shown. When trying to acces the Message MasterA works fine but MasterB does not show me the property of D.

Is there like a maximum number of Messages, or what could be the reason? Since Message MasterA builds fine, I think I've done everything right concerning message generation and so on..

Sorry for the bad explanation, but i don't know how to describe the problem any better.

Thank you in advance

edit retag flag offensive close merge delete

Comments

1

Can you show us the message definition of MasterB. Also what exactly do you mean by

MasterB does not show me the property of D

Can you access each of its members apart from the instance of D?

PeteBlackerThe3rd gravatar image PeteBlackerThe3rd  ( 2019-02-19 12:03:53 -0500 )edit

"Can you access each of its members apart from the instance of D?"

Yes, that was exactly my problem. The reason seemed to be, that i added D to the message definition after I builded the project for the first time.

MarcelKr gravatar image MarcelKr  ( 2019-02-20 01:55:00 -0500 )edit

@MarcelKr: please post your last edit as an answer and accept your own answer.

That way it's much clearer that you've resolved your issue.

gvdhoorn gravatar image gvdhoorn  ( 2019-02-20 02:16:00 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-20 02:57:16 -0500

MarcelKr gravatar image

Edit: Managed to solve the problem!

The problem was, that I edited the message after I defined it. I don't know why but CMAKE seems to stick on the original definition, even after deleting the msg.h-files. After deleting the whole project and rebuilding it, everything works fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-02-19 06:38:52 -0500

Seen: 57 times

Last updated: Feb 20 '19