Hector slam slow at making map

asked 2019-02-04 07:00:07 -0500

updated 2019-02-04 07:03:17 -0500

Hi i am running ros medoldic, i want to use a ydlidar x4 and hector slam without odometry, I am running a rosbag file to simulate the time, my tf tree looks like( because i cant post pictrues) world -> map -> base_footprint ->laser_frame

it seams to be very slow I dont know if its my tf tree i added in the launch file is affecting my problem

Ive added these lines to the ydliadar laser scan launch file

<node pkg="tf" type="static_transform_publisher" name="base_link_to_laser" args="0.2245 0.0 0.2 0.0 0.0 0.0/base_footprint /laser_frame 40"/>

 <node pkg="tf" type="static_transform_publisher" name="link1_broadcaster" args="1 0 0 0 0 0 1 /world /map 100" />

 <node pkg="tf" type="static_transform_publisher" name="link2_broadcaster" args="1 0 0 0 0 0 1 /map /base_footprint 99" />

(this might not be best practice)

Thanks

edit retag flag offensive close merge delete

Comments

Can you post the parameters you are using for hector? Also, you are publishing a static transform from map to base_footprint, which is probably incorrect. This transform represents the vehicle moving around map frame, and is what hector should be providing as part of its localization output.

robustify gravatar imagerobustify ( 2019-02-04 09:42:43 -0500 )edit