SROS - keys are not being created

asked 2019-02-04 01:10:43 -0600

Gil404 gravatar image

Hi, I am trying to replace the ROS infra to SROS by following the tutorial on http://wiki.ros.org/SROS/Installation I ran the sroskeyserver but it seems that keys are not being created (under the keyserver/nodes) for my nodes and therefore i am unable to connect the nodes to sroscore.

Any idea what i could be missing?

Thank you!

edit retag flag offensive close merge delete

Comments

Just making sure you've seen it (from here):

SROS is currently highly experimental and under heavy development.

Most of the development effort has gone into SROS2, which is trying to do the same for ROS2, but from the start, and with the help of antive DDS ..

gvdhoorn gravatar imagegvdhoorn ( 2019-02-04 05:42:47 -0600 )edit

.. security frameworks.

Not saying you shouldn't use/take look at SROS, but just wanted to make sure you're aware of the experimental nature and status of it (ie: Python only support, etc).

gvdhoorn gravatar imagegvdhoorn ( 2019-02-04 05:43:18 -0600 )edit

Hi @gvdhoorn, thanks for the reply.

Yeah I am aware of it, but since ROS2 is also still not baked enough I am trying to use what I can in ROS1.0

Gil404 gravatar imageGil404 ( 2019-02-04 06:11:03 -0600 )edit