DWB_local_planner slows down while avoiding obstacles.

asked 2019-01-29 09:08:46 -0500

Mobile_robot gravatar image

updated 2019-01-29 09:15:54 -0500

Dear all,

While trying to avoid obstacle (dynamic and static) by the DWB_local_planner, the robot slows down to its min_vel_x.

I believe the problem comes from the way that I have configured the DWB_local_planner parameters (specially that I am not sure about the max_scaling_factor and scaling_speed).

Do you have any idea why it behaves like this?

Here you can find my current configuration:

acc_lim_x: 0.5
acc_lim_th: 0.5

# Robot Configuration Parameters
max_vel_x: 1.0
min_vel_x: 0.1 

max_trans_vel: 1.0
min_trans_vel: 0.1

max_trans_vel: 1.0
min_trans_vel: 0.0

max_rot_vel: 0.628 
min_rot_vel: 0.2 

# Goal Tolerance Parameters
yaw_goal_tolerance: 0.15 
xy_goal_tolerance: 0.5 
latch_xy_goal_tolerance: false

# Forward Simulation Parameters
sim_time: 4.0 
sim_granularity: 0.025
vx_samples: 6
vy_samples: 0 
vtheta_samples: 30
controller_frequency: 10
#meter_scoring: true
#penalize_negative_x: false

# Trajectory Scoring Parameters
path_distance_bias: 12
goal_distance_bias: 10
occdist_scale: 14.0
forward_point_distance: 0.325
stop_time_buffer: 0.2
scaling_speed: 0.25
max_scaling_factor: 0.2

# Oscillation Prevention Parameters
oscillation_reset_dist: 0.05 

# Debugging
publish_traj_pc : true
publish_cost_grid_pc: true
global_frame_id: map

# Global Plan Parameters
prune_plan: true

The test without inflation image description

The test with inflation (cost_scaling_factor: 0) image description

Thanks a lot,

edit retag flag offensive close merge delete

Comments

A) I'm not sure what your diagrams are showing B) What do you think it should do instead?

David Lu gravatar imageDavid Lu ( 2019-01-29 16:01:32 -0500 )edit

Thanks David for your comment.

A) In order to indicate that this behavior of the DWB_local_planner is not related to the distance between the footprint and the obstacle.

Mobile_robot gravatar imageMobile_robot ( 2019-01-30 02:39:01 -0500 )edit

B) I think the fact that it slows down is logical but I do not understand why the DWB sets the robot's velocity to the min_vel_x. The robot is too slow while detecting an obstacle and while avoiding it which leads to a not satisfying behavior.

Mobile_robot gravatar imageMobile_robot ( 2019-01-30 02:42:31 -0500 )edit

This is why I was wondering if I have done any mistake while configuring the parameters.

Mobile_robot gravatar imageMobile_robot ( 2019-01-30 02:43:25 -0500 )edit

Does it get better when you turn down sim_time?

David Lu gravatar imageDavid Lu ( 2019-02-11 12:07:44 -0500 )edit

I have tried that but unfortunately I saw no changes.

Mobile_robot gravatar imageMobile_robot ( 2019-02-18 07:09:01 -0500 )edit

Can you record the DWBLocalPlanner/evaluation topic and post it here?

David Lu gravatar imageDavid Lu ( 2019-02-19 15:50:58 -0500 )edit