Ask Your Question
0

Failed to connect RealSense camera using realsense2_camera package

asked 2019-01-14 22:38:52 -0500

anirban gravatar image

updated 2019-01-16 21:37:11 -0500

jayess gravatar image

I am trying to install realsense ros packages following the instruction https://github.com/intel-ros/realsense. I have successfully built librealsense from source using the instruction given in https://github.com/IntelRealSense/lib... . Then I cloned the git repository of realsense2_camera package into the src folder of catkin_ws directory. After that I did catkin_make and everything worked fine. Then I connect the realsense camera to the computer and ran the following

roslaunch realsense2_camera rs_camera.launch

and got the errror given at the end.

Can anyone point me to resolve the issue?

Thank you in advance

ERROR MESSAGE

$ roslaunch realsense2_camera rs_camera.launch

... logging to /home/nobug-ros/.ros/log/741bfb4a-19ee-11e9-a2a2-642737b8e683/roslaunch-nobug-18599.log

Checking log directory for disk usage. This may take awhile.

Press Ctrl-C to interrupt

Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://nobug:39973/

summary

PARAMETERS
 * /camera/realsense2_camera/accel_fps: 250
 * /camera/realsense2_camera/accel_optical_frame_id: camera_accel_opti...
 * /camera/realsense2_camera/align_depth: False
 * /camera/realsense2_camera/aligned_depth_to_color_frame_id: camera_aligned_de...
 * /camera/realsense2_camera/aligned_depth_to_fisheye_frame_id: camera_aligned_de...
 * /camera/realsense2_camera/aligned_depth_to_infra1_frame_id: camera_aligned_de...
 * /camera/realsense2_camera/aligned_depth_to_infra2_frame_id: camera_aligned_de...
 * /camera/realsense2_camera/base_frame_id: camera_link
 * /camera/realsense2_camera/clip_distance: -2.0
 * /camera/realsense2_camera/color_fps: 30
 * /camera/realsense2_camera/color_frame_id: camera_color_frame
 * /camera/realsense2_camera/color_height: 480
 * /camera/realsense2_camera/color_optical_frame_id: camera_color_opti...
 * /camera/realsense2_camera/color_width: 640
 * /camera/realsense2_camera/depth_fps: 30
 * /camera/realsense2_camera/depth_frame_id: camera_depth_frame
 * /camera/realsense2_camera/depth_height: 480
 * /camera/realsense2_camera/depth_optical_frame_id: camera_depth_opti...
 * /camera/realsense2_camera/depth_width: 640
 * /camera/realsense2_camera/enable_color: True
 * /camera/realsense2_camera/enable_depth: True
 * /camera/realsense2_camera/enable_fisheye: True
 * /camera/realsense2_camera/enable_imu: True
 * /camera/realsense2_camera/enable_infra1: True
 * /camera/realsense2_camera/enable_infra2: True
 * /camera/realsense2_camera/enable_pointcloud: False
 * /camera/realsense2_camera/enable_sync: False
 * /camera/realsense2_camera/filters: 
 * /camera/realsense2_camera/fisheye_fps: 30
 * /camera/realsense2_camera/fisheye_height: 480
 * /camera/realsense2_camera/fisheye_optical_frame_id: camera_fisheye_op...
 * /camera/realsense2_camera/fisheye_width: 640
 * /camera/realsense2_camera/gyro_fps: 400
 * /camera/realsense2_camera/gyro_optical_frame_id: camera_gyro_optic...
 * /camera/realsense2_camera/infra1_fps: 30
 * /camera/realsense2_camera/infra1_frame_id: camera_infra1_frame
 * /camera/realsense2_camera/infra1_height: 480
 * /camera/realsense2_camera/infra1_optical_frame_id: camera_infra1_opt...
 * /camera/realsense2_camera/infra1_width: 640
 * /camera/realsense2_camera/infra2_fps: 30
 * /camera/realsense2_camera/infra2_frame_id: camera_infra2_frame
 * /camera/realsense2_camera/infra2_height: 480
 * /camera/realsense2_camera/infra2_optical_frame_id: camera_infra2_opt...
 * /camera/realsense2_camera/infra2_width: 640
 * /camera/realsense2_camera/initial_reset: False
 * /camera/realsense2_camera/json_file_path: 
 * /camera/realsense2_camera/linear_accel_cov: 0.01
 * /camera/realsense2_camera/pointcloud_texture_index: 0
 * /camera/realsense2_camera/pointcloud_texture_stream: RS2_STREAM_COLOR
 * /camera/realsense2_camera/rosbag_filename: 
 * /camera/realsense2_camera/serial_no: 
 * /camera/realsense2_camera/unite_imu_method: 
 * /rosdistro: kinetic
 * /rosversion: 1.12.14

NODES
  /camera/
    realsense2_camera (nodelet/nodelet)
    realsense2_camera_manager (nodelet/nodelet)

auto-starting new master
process[master]: started with pid [18609]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 741bfb4a-19ee-11e9-a2a2-642737b8e683
process[rosout-1]: started with pid [18622]
started core service [/rosout]
process[camera/realsense2_camera_manager-2]: started with pid [18625]
process[camera/realsense2_camera-3]: started with pid [18626]
[ INFO] [1547684756.584657520]: Initializing nodelet with 4 worker threads.
[ INFO] [1547684756.680487808]: RealSense ROS v2.1.2
[ INFO] [1547684756.680546036]: Running with LibRealSense v2.17.1
[ERROR] [1547684756.850043496]: No RealSense devices were found! Terminating RealSense Node...
[FATAL] [1547684757.004131073]: Failed to load nodelet '/camera/realsense2_camera` of type `realsense2_camera/RealSenseNodeFactory` to manager `realsense2_camera_manager'
[camera/realsense2_camera_manager-2] process has died [pid 18625, exit code 1, cmd /opt/ros/kinetic/lib/nodelet/nodelet manager __name:=realsense2_camera_manager __log:=/home/nobug-ros/.ros/log/741bfb4a-19ee-11e9-a2a2-642737b8e683/camera-realsense2_camera_manager-2.log].
log file: /home/nobug-ros/.ros/log/741bfb4a-19ee-11e9-a2a2-642737b8e683/camera-realsense2_camera_manager-2*.log
[camera/realsense2_camera-3] process has died [pid 18626, exit code ...
(more)
edit retag flag offensive close merge delete

Comments

Did you tamper with the launch file? Can you run realsense-viewer on its own?

aPonza gravatar imageaPonza ( 2019-01-15 05:31:05 -0500 )edit

I did not make any changes to the launch file. However realsense-viewer works fine, I can see infrared data through it.

anirban gravatar imageanirban ( 2019-01-15 22:35:38 -0500 )edit

Just noticed we have a different camera, you have D415 right? Anyways, I don't even get the warnings, so like to ask you to add the whole log from roslaunch until the end, as a text maybe instead of a picture... something else should be the issue here.

aPonza gravatar imageaPonza ( 2019-01-16 02:24:11 -0500 )edit

Wait, even before that, try reading github issue #301 where another person had likely similar output: the problem seems to be solved by using a USB 3.0 port instead of a 2.0

aPonza gravatar imageaPonza ( 2019-01-16 02:27:26 -0500 )edit

@aPonza The camera is connected to a USB 3.0 port and I still face the error. Because of character limitations I can not provide the Error Log as text here, instead I have updated the question will complete error images

anirban gravatar imageanirban ( 2019-01-16 15:41:28 -0500 )edit

Please don't use an image to display text. Images are not searchable and people cannot copy and paste the text from the image. Please update your question with a copy and paste of the text instead of an image.

jayess gravatar imagejayess ( 2019-01-16 17:47:15 -0500 )edit

I have updated the question with error messages in simple text.

anirban gravatar imageanirban ( 2019-01-16 18:37:07 -0500 )edit

@aPonza please see the updated question with error message

anirban gravatar imageanirban ( 2019-01-16 18:39:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-08 05:16:28 -0500

aryanna003 gravatar image

updated 2019-03-08 19:50:02 -0500

jayess gravatar image

try :

roslaunch realsense2_camera rs_rgbd.launch

i use ros melodic on ubuntu 18 and it run with realsense d435

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-01-14 22:38:52 -0500

Seen: 571 times

Last updated: Mar 08