Ask Your Question
0

rviz does not show 3d objects from urdf

asked 2019-01-14 10:52:13 -0600

tommy3001 gravatar image

Hallo.

I try to follow the tutorial urdf Tutorials/ Building a Visual Robot Model with URDF from Scratch

The Problem what I have is that the 3d Objects are not visible. I can only see the arrows of the x/y/z axis at the joints which are moving when I change the values for the joint angle in the Gui of the joint_state_publisher.

I use melodic and I got the files directly from the Github repository. I started with: roslaunch urdf_tutorial display.launch model:=src/urdf_tutorial/urdf/06-flexible.urdf

It seems to be a general issue, because I got the same problem with other downloaded urdf-examples and all urdf files of this tutorial.

Visual in the RobotModel is in the preferences enabled and when I set TF prefix to false, the arrays of the coordinates in the origin of the not visible objects are also not visible.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-01-14 11:34:31 -0600

gvdhoorn gravatar image

updated 2019-01-14 11:35:27 -0600

You're probably running into something similar to #q272692. For now that still requires a work-around, until the fixes applied to the affected packages have been propagated upstream (they're in Ubuntu/Debian).

edit flag offensive delete link more

Comments

Thanks for the Comment.

export LC_NUMERIC="en_US.UTF-8"

before launch solved the problem for me.

tommy3001 gravatar imagetommy3001 ( 2019-01-14 11:40:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-01-14 09:40:11 -0600

Seen: 147 times

Last updated: Jan 14 '19