Ask Your Question
1

ROS 2 Crystal in 16.04 - failing

asked 2018-12-28 06:06:06 -0500

nzlz gravatar image

Hi everyone,

I am trying to install ros2 crystal from source in a clean Ubuntu 16.04 machine. My first surprise is that there are opensplice related packages, which fail to install (no opensplice related dependencies are installed as pre-requirements). But even If a few packages fail, it should still be possible to compile the rest of the workspace and source those good packages correctly.

I have tried ignoring packages related to opensplice, but does not seem to be the main issue. The output I get after I build the workspace following the official instructions (using .repos from release-crystal-20181214) is the following. Note that all the failing packages except ros1_bridge have a connection to opensplice:

Summary: 226 packages finished [1h 12min 39s]
  8 packages had stderr output: rmw_connext_cpp rmw_connext_shared_cpp rmw_opensplice_cpp ros1_bridge rosidl_typesupport_connext_c rosidl_typesupport_connext_cpp rosidl_typesupport_opensplice_c rosidl_typesupport_opensplice_cpp

Sourcing the installation fails, the output is available in this github gist.

I am using a second overlay workspace which fails to build because the main ros2_ws does not provide a correct source.

Any kind of help is much appreciated! Thanks in advance,

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-12-28 11:45:47 -0500

Dirk Thomas gravatar image

Your output doesn't show any failed packages - only packages which printed to stderr:

Summary: 226 packages finished [1h 12min 39s]
  8 packages had stderr output: ...

Without the actual output being shared I have to guess: the Connext-related packages likely print a warning that since Connext is not available they will not provide any functionality. The very same for the OpenSplice-related ones. And for the ros1_bridge since you didn't have ROS 1 sourced the warning message lets you know that the bridge is being skipped.

Therefore the resulting installation should work fine using FastRTPS.

I am using a second overlay workspace which fails to build because the main ros2_ws does not provide a correct source.

I don't understand what this means. Please descibe in more detail what fails and what sources you expect which you think are missing.

edit flag offensive delete link more

Comments

What I mean is, when I source the ros2 ws, I am getting some strange output. This is not the expected output.

source ~/ros2_ws/install/local_setup.bash 
not found: "/home/erle/ros2_ws/install/ament_clang_format
ament_copyright
...

Please check the link to the Gist file above.

nzlz gravatar imagenzlz ( 2018-12-28 11:58:43 -0500 )edit

What shell are you using?

Dirk Thomas gravatar imageDirk Thomas ( 2018-12-28 11:59:42 -0500 )edit

Default Linux bash.

nzlz gravatar imagenzlz ( 2018-12-28 12:37:59 -0500 )edit
1

Could it be that you have modified the IFS in your bash profile?

Dirk Thomas gravatar imageDirk Thomas ( 2018-12-28 13:01:03 -0500 )edit

Surely something happened with my bash profile. The source is working correctly after a simple reboot. Thanks!

nzlz gravatar imagenzlz ( 2018-12-28 17:07:11 -0500 )edit
0

answered 2018-12-28 17:11:26 -0500

nzlz gravatar image

Ask Dirk-Thomas suggested, the failure of the source operation was related to some temporary env variable or bash profile. Whatever it was, a simple reboot fixed the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-12-28 06:06:06 -0500

Seen: 503 times

Last updated: Dec 28 '18