How to improve/tune Amcl performance

asked 2018-12-26 06:26:56 -0600

jamess gravatar image

Hello friends,

I managed to run amcl_omni.launch without any warning info but mapping performance is really low.

I used scanse sweep lidar in 10 Hz , I checked the data in rviz it looks reasonable . I also create map with this lidar , I think it's working as expected. I am using mit-racecar configuration as car and vesc , I get odom data from mit-racecar github repo, I did not edit any part of it gives me data I am not sure if it is correct but when i check it as rostopic echo /tf i see odom -> base_link tf is reasonable. At rviz i set pose estimation point , it sets closely to real place , so many poses appear . When i move car around map pose numbers not getting lower, laser points not getting match with wall.

How should i fix these problem . I tried amcl_diff.launch and amcl_omni.launch. Both of them not working correctly.

edit retag flag offensive close merge delete

Comments

Could you give a bit more information?

-How many sensors are you using

-Are you computing any odometry

-Are you feeding that odometry to AMCL

-Does this issue happen both when you move forward and rotate

-What type of drive system you have(I assume ackerman because you said car but unsure)

juanlu gravatar imagejuanlu ( 2019-01-03 08:13:19 -0600 )edit

I am using 1 lidar Scance Sweep and 1 vesc for creating odom data. I used ackerman like you said. I figured out that my lidar got problem when using at 10 Hz all the time. I decreased it to 5 Hz , now it works without problem. I figured out that my odom data is not precise in both forward and rotate

jamess gravatar imagejamess ( 2019-01-07 00:51:37 -0600 )edit

.... Most effective change that i make is i add some parameters to amcl launch file from Jackal Navigation tutorials amcl launch file. I don't know which parameters do what but i manage to run it better.

jamess gravatar imagejamess ( 2019-01-07 00:53:08 -0600 )edit