Ask Your Question
0

Problem building rosjava_core and android_core (couldn't find install_generated_modules.py)

asked 2012-04-03 08:31:10 -0500

bblodget gravatar image

I am trying to build rosjava_core and android_core from source. Here are the steps I've tried:

hg clone https://code.google.com/p/rosjava rosjava_core
hg clone https://code.google.com/p/rosjava.android android_core

From http://docs.rosjava.googlecode.com/hg/rosjava_core/html/building.html

roscd rosjava_core
./gradlew install

BUILD SUCCESSFUL
Total time: 1 mins 13.005 secs

From http://docs.rosjava.googlecode.com/hg/android_core/html/building.html

roscd android_core
rosrun rosjava_bootstrap install_generated_modules.py android_tutorial_pubsub

[rosrun] Couldn't find executable named install_generated_modules.py below /home/brandonb/ros_android3/rosjava_core/rosjava_bootstrap

I looked in the rosjava_core/rosjava_bootstrap directory and there is no scripts directory where the install_generated_modules.py used to be.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-04-03 09:11:48 -0500

Jyo gravatar image

The person in charge of rosjava and rosjava.android updated rosjava with some significant internal changes yesterday, however has not updated the android portion. My guess is that you will need to use the previous version of rosjava until he does...

edit flag offensive delete link more

Comments

Thanks. Do you have a suggestion for what previous version I should try? I tried change set 954:ff50a6891058 from March 14th but ./gradlew install failed.

bblodget gravatar image bblodget  ( 2012-04-03 10:43:12 -0500 )edit
1

android_core and the associated documentation have been updated and build correctly again.

damonkohler gravatar image damonkohler  ( 2012-04-03 22:07:52 -0500 )edit

Great! I have android_core building successfully now. I also had to "hg clone https://code.google.com/p/rosjava.google rosjava_google" and run "gradlew install" on that because I was getting an error about "compressed_visualization_transport_msgs does not exist" during the android_core build.

bblodget gravatar image bblodget  ( 2012-04-04 09:10:05 -0500 )edit
0

answered 2012-04-04 09:31:50 -0500

alexbeta20 gravatar image

Hi, while building android_core using $./gradlew debug, I got following error.

BUILD FAILED /home/alex/ros_workspace/android_core/android_honeycomb_mr2/build.xml:46: sdk.dir is missing. Make sure to generate local.properties using 'android update project' or to inject it through an env var

What should I do with that?? Thank you.

edit flag offensive delete link more

Comments

I think you need to install the Android 3.2 (API 13) SDK Platform which is required by android_honeycomb_mr2. You can download this using the Android SDK Manager which you can start by typing "android" at the command line.

bblodget gravatar image bblodget  ( 2012-04-04 10:51:32 -0500 )edit

yep!!! You must be right! I forget to download the 3.2 API.....I will try to fix the problem. Thank you!!

alexbeta20 gravatar image alexbeta20  ( 2012-04-04 15:22:48 -0500 )edit
1

I'll update the documentation with the extra steps outlined here.

damonkohler gravatar image damonkohler  ( 2012-04-05 09:24:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-04-03 08:31:10 -0500

Seen: 524 times

Last updated: Apr 04 '12