Ask Your Question
0

Joy sometimes changes linux controller mapping

asked 2018-12-18 17:17:16 -0500

PG_GrantDare gravatar image

updated 2018-12-19 15:55:02 -0500

Hi everyone,

When launching joy I occasionally experience a case where I have a wired xbox360 controller plugged to the machine and joy instead uses wireless mapping? This is obviously an issue for when I am operating my robot as the left trigger for wired mapping is Left/Right Axis stick right for wireless mapping. Can anyone point me to if there is an option to force joy to use a wired mapping or perhaps if it is xboxdrv that is presenting the issue?

Thanks in advance for all help.

EDIT in response to gvdhoorns comment: The Joy package maps the arrays of axes and buttons differently depending on whether the controller is wired or wireless. My problem is that the controller is always wired but occasionally will map to wireless.

edit retag flag offensive close merge delete

Comments

1

At least for me personally it would help if you could clarify what a "wireless mapping" and a "wired mapping" are.

gvdhoorn gravatar imagegvdhoorn ( 2018-12-19 03:02:54 -0500 )edit

@gvdhoorn edit added

PG_GrantDare gravatar imagePG_GrantDare ( 2018-12-19 15:55:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-17 17:06:50 -0500

PG_GrantDare gravatar image

updated 2019-04-17 17:07:13 -0500

This problem was solved. It appears that on an older computer (not my own) xboxdrv and xpad were fighting for the controller. Based on who got it first was the mapping. I uninstalled xboxdrv and kept xpad and solved this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-12-18 17:17:16 -0500

Seen: 49 times

Last updated: Apr 17