Ask Your Question
0

Couldn't find executable named camaracalibrator.py

asked 2018-12-13 03:04:31 -0600

venushka gravatar image

I am new to ros and its developing. By following this link . i try calibrate uvc camera. Upto Installation of calibration related packages is done. But when i try to run

rosrun camera_calibration camaracalibrator.py --size 8x6 --square 0.025 image: = / image_raw

i get following errors . Any help is appreciated. Thank you in advance.

rosrun camera_calibration camaracalibrator.py --size 8x6 --square 0.025 image: = / image_raw
[rosrun] Couldn't find executable named camaracalibrator.py below /opt/ros/kinetic/share/camera_calibration
edit retag flag offensive close merge delete

Comments

I think you should try to get the dependencies and compiling the drivers as mentioned in this tutorial first. and also try $ rosmake camera_calibration before running the camera calibration node

Rasika gravatar imageRasika ( 2018-12-13 05:34:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-13 10:54:47 -0600

It seems the page you referring to has a typo. The node is actually called cameracalibrator.py. Also you added spaces in the ROS parameter assignment and the topic namespace, so pay attention.

The command should be:

rosrun camera_calibration cameracalibrator.py --size 8x6 --square 0.025 image:=/image_raw

The easiest way to avoid such problems is to type in everything yourself (do not copy/paste) and use bash-completion by pressing Tab. ROS command-line tools have pretty good completion support for most of parameters. In case of rosrun the completion is very helpful for package names (first parameter) and node names (second parameter); note, however, to make this to work for your own nodes the script should be actually marked as executable on the file system with, e.g. chmod a+x <script name>

edit flag offensive delete link more

Comments

@Boris thank you after running it i got this problem , do you have any idea https://stackoverflow.com/questions/5... the usb camera that i use i tested with cheese command. it works well.

venushka gravatar imagevenushka ( 2018-12-14 03:35:06 -0600 )edit

From a quick glance the command used on the link you've provided is also wrong: again there are spaces where they shouldn't be. Make sure that parameter assignment has no spaces, i.e. exactly like this image:=/image_raw. Also make sure that the topic exists with rostopic info /image_raw

Boris gravatar imageBoris ( 2018-12-14 04:14:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-12-13 02:42:26 -0600

Seen: 157 times

Last updated: Dec 13 '18