Ask Your Question
0

No laser scan received

asked 2018-12-07 07:11:49 -0500

RoboRos gravatar image

updated 2018-12-10 07:23:14 -0500

Hello,

I know this question has been asked many times for single robot but i cannot figure it out for my multi-robot-system. Please Note: It is perfectly working for a single robot. But it is giving the error below when launching multiple robots.

    No laser scan received (and thus no pose updates have been published) for 18.505000 seconds.  Verify that data is being published on the /plato1/scan topic.
[ WARN] [1544187859.336072043, 18.505000000]: MessageFilter [target=odom ]: Dropped 100.00% of messages so far. Please turn the [ros.amcl.message_notifier] rosconsole logger to DEBUG for more information.
[ WARN] [1544187859.350568657, 18.515000000]: No laser scan received (and thus no pose updates have been published) for 18.515000 seconds.  Verify that data is being published on the /plato2/scan topic.
[ WARN] [1544187859.350708006, 18.515000000]: MessageFilter [target=odom ]: Dropped 100.00% of messages so far. Please turn the [ros.amcl.message_notifier] rosconsole logger to DEBUG for more information.

Now, the problem is that data is being published on the topics (/plato1/scan and /plato2/scan). But somehow this error is causing me problems.

I am running it in Gazebo simulation.

(((Below is the pdf file of the tf tree. Please download it))) https://drive.google.com/file/d/1Fmvq...

Any help please!

edit retag flag offensive close merge delete

Comments

1

Can you tell us more about your setup. Are you using multiple on board computers? Have you checking messages can be passed between them okay? What does rqt_graph show on each machine?

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-12-07 07:51:57 -0500 )edit

@pete Well, it is in simulation (gazebo). So, it is working.

RoboRos gravatar imageRoboRos ( 2018-12-08 15:06:16 -0500 )edit

The most imortant thing is actually MessageFilter [target=odom ]: Dropped 100.00% of messages so far.. This is from tf, which is used to transform the laserscan into the map frame. As this is simulation, I'm assuming you are running this on a single computer. Have you checked the tf setup? ...

mgruhler gravatar imagemgruhler ( 2018-12-10 03:16:43 -0500 )edit

You need to have seperate trees for both robots. This is hard to achieve, and since tf2removed tf_prefix support it is even harder to achieve now. Though it wasn't super easy to begin with... ...

mgruhler gravatar imagemgruhler ( 2018-12-10 03:18:04 -0500 )edit

to go further in debugging, please post a picture of your tf tree, e.g. using rosrun tf view_frames.

mgruhler gravatar imagemgruhler ( 2018-12-10 03:18:47 -0500 )edit

@mgruhler I have attached the tf tree in pdf format. You need to edit the extension (remove .jpg to view pdf).

RoboRos gravatar imageRoboRos ( 2018-12-10 04:48:55 -0500 )edit

@RoboRos when you edit the question, you can embedd it by clicking on the "image" link above the edit window. I can't access the image the way you integrated it.

mgruhler gravatar imagemgruhler ( 2018-12-10 04:54:48 -0500 )edit

You can download the file from the below link: (image wont be able to present the whole tree): . https://drive.google.com/file/d/1Fmvq...

RoboRos gravatar imageRoboRos ( 2018-12-10 07:24:19 -0500 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2018-12-10 09:10:44 -0500

mgruhler gravatar image

Alright, having this as an embedded image would be nicer. But given the width of it, I see your problem ;-)

My guess is the problem comes from the SLAM (whatever it may be) actually looking for the frame odom, whereas it should look for plato1/odom. You would need to adapt the config of the SLAM, if it has something like an odom_frame parameter. If it is hard-coded (what I've seen some times), you might have to change the source code...

edit flag offensive delete link more

Comments

yup, yup, solved. Thanks for your help. I was not providing proper (frames or parameters) to amcl.

RoboRos gravatar imageRoboRos ( 2018-12-11 04:58:11 -0500 )edit

i'm the same problem, what have you changed? Thanks for your help

aryanna003 gravatar imagearyanna003 ( 2019-03-21 11:42:04 -0500 )edit

The same Problem? Well, i was not providing the correct topics (or call it name space). You need to pass the correct namespace forexample: for single robot the topic can be: /odom... but for multiple robots it is: /robot1/odom .... /robot2/odom and so on.....

RoboRos gravatar imageRoboRos ( 2019-03-21 15:03:07 -0500 )edit

my name topic are correct.. :-( the topic to subscribe is : /scan /odom /tf is corretc?

aryanna003 gravatar imagearyanna003 ( 2019-03-22 03:59:18 -0500 )edit

Pid: 25146 Connections: * topic: /rosout * to: /rosout * direction: outbound * transport: TCPROS

aryanna003 gravatar imagearyanna003 ( 2019-03-22 04:38:32 -0500 )edit

@aryanna003 if the above does not directly solve your problem, it might be beneficial if you create a new question with all the respective information. This way, more people will actually see it...

mgruhler gravatar imagemgruhler ( 2019-03-22 06:47:35 -0500 )edit
aryanna003 gravatar imagearyanna003 ( 2019-03-22 08:18:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-12-07 07:11:49 -0500

Seen: 179 times

Last updated: Dec 10 '18