Ask Your Question
0

Couldn't find executable named gscam below /home/my_pc/ros/gscam [closed]

asked 2018-12-06 07:10:41 -0600

Akeyn gravatar image

updated 2018-12-06 09:34:35 -0600

Hi all!

I have problem like this -

user@PC:~/ros$ rosrun gscam gscam
[rosrun] Couldn't find executable named gscam below /home/user/ros/gscam
[rosrun] Found the following, but they're either not files,
[rosrun] or not executable:
[rosrun]   /home/user/ros/gscam
[rosrun]   /home/user/ros/gscam/include/gscam

Does anyone explain what I'm doing wrong?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Akeyn
close date 2018-12-06 13:40:22.624612

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-06 08:37:16 -0600

krl101 gravatar image

Hi there!

assuming your workspace have been build successfully, inclusive the add_executable(...) / target_link_libraries(..) and add_dependencies in your CMakeList.txt ( although named gscam).

Are you sure that "gscam" (the first own) is your package, the second is your executable and your devel/setup.bash is sourced?

edit flag offensive delete link more

Comments

The gscam package was downloaded from https://github.com/ros-drivers/gscam , and i added package in my home directory in ros folder. Before i used ros tools in this directory, i typed into the terminal this: export ROS_PACKAGE_PATH=~/ros:$ROS_PACKAGE_PATH. And then: source /opt/ros/kinetic/setup.bash

Akeyn gravatar imageAkeyn ( 2018-12-06 09:06:29 -0600 )edit

Yea, gscam/devel/setup.bash is sourced

Akeyn gravatar imageAkeyn ( 2018-12-06 11:30:21 -0600 )edit

I am not very firm with ROS_PACKAGE_PATH, but should it be: export ROS_PACKAGE_PATH=${ROS_PACKAGE_PATH}:/home/my_pc/ros/gscam -> ${ROS_PACKAGE_PATH} to append the new path

krl101 gravatar imagekrl101 ( 2018-12-07 01:38:48 -0600 )edit

Question Tools

Stats

Asked: 2018-12-06 07:10:41 -0600

Seen: 32 times

Last updated: Dec 06 '18