Ask Your Question
0

Installing ROS in centOS

asked 2012-04-02 00:33:15 -0500

anonymous user

Anonymous

updated 2014-04-20 14:09:41 -0500

ngrennan gravatar image

Hi all, Is there any way I can install ROS in centOS? I get this error even if I try to install minimum packages.

[ rosmake ] rosdep install failed: Could not detect OS, tried ['rosdep_test_os', 'debian', 'ubuntu', 'ubuntu', 'opensuse', 'fedora', 'rhel', 'arch', 'osx', 'osxbrew', 'gentoo', 'cygwin', 'freebsd']

I know ROS is not yet ready for centOS, but did anyone tried, any tricks to make it work?

Thanks in advance, dksr

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-04-02 07:32:50 -0500

tfoote gravatar image

You might be able to use the ROS_OS_OVERRIDE environment variable and tell rosdep that you're running rhel. RHEL is not heavily used either so you may need to generate new rules for system dependencies for that as well.

There are some tutorials on updating rules on the rosdep wiki page

edit flag offensive delete link more

Comments

I'm trying to install ROS on CentOS as well. I've tried setting ROS_OS_OVERRIDE to rhel, but for many many packages I get a "No definition of [PACKAGENAME] for os [rhel]". I'm totally new to ROS and am required to use CentOS for this. Can you point me in the right direction to resolving this issue?

jrwilliams gravatar image jrwilliams  ( 2014-02-27 06:32:36 -0500 )edit

You will need to contribute rosdep rules for the package for CentOS http://docs.ros.org/independent/api/rosdep/html/contributing_rules.html has instructions on how to do so.

tfoote gravatar image tfoote  ( 2014-02-27 07:10:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-02 00:33:15 -0500

Seen: 2,748 times

Last updated: Apr 02 '12