Ask Your Question
0

Wheels using ROS skid steer controller can't turn

asked 2018-12-01 10:06:01 -0500

the3kr gravatar image

updated 2019-03-18 03:02:50 -0500

I've created a four-wheeled robot with skid steer controller which works with teleop_twist_keyboard node. However the robot can only move forward or backward and I can't get it to turn left or right.

The skidsteer controller:

<gazebo>
    <plugin name="skid_steer_drive_controller" filename="libgazebo_ros_skid_steer_drive.so">
          <updateRate>100.0</updateRate>
          <robotNamespace>/</robotNamespace>   
          <leftFrontJoint>left_front_wheel_joint</leftFrontJoint>
          <rightFrontJoint>right_front_wheel_joint</rightFrontJoint>
          <leftRearJoint>left_back_wheel_joint</leftRearJoint>
          <rightRearJoint>right_back_wheel_joint</rightRearJoint>
          <wheelSeparation>5</wheelSeparation>
          <wheelDiameter>0.6</wheelDiameter> 
          <robotBaseFrame>base_footprint</robotBaseFrame>  
          <torque>20</torque>
          <topicName>/cmd_vel</topicName>
          <broadcastTF>true</broadcastTF>
          <commandTopic>/cmd_vel</commandTopic>
          <odometryTopic>/odom</odometryTopic>
          <odometryFrame>/odom</odometryFrame>
          <covariance_x>0.0001</covariance_x>
          <covariance_y>0.0001</covariance_y>
          <covariance_yaw>0.0001</covariance_yaw>
    </plugin>
</gazebo>

<gazebo>
    <plugin name="gazebo_ros_control" filename="libgazebo_ros_control.so">
        <robotNamespace>/</robotNamespace>
    </plugin>
</gazebo>

Thanks.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2019-03-18 03:07:50 -0500

the3kr gravatar image

I'm not sure why but adding contact stiffness, friction co-efficient and damping fixed it. Like:

<kp>1000000.0</kp> <!-- kp and kd for rubber -->
<kd>100.0</kd>
<mu1>1.0</mu1>
<mu2>1.0</mu2>
<maxVel>1.0</maxVel>
<minDepth>0.00</minDepth>
edit flag offensive delete link more
1

answered 2020-06-15 22:39:19 -0500

wfcola gravatar image

HI,I just got the same problem,and i fixed it with the following steps: 1.Upside down your model in gazebo with tools in toolsbar. 2.Control the wheels and see if they are turing in right direction. This step is to make sure that your plugin is working fine. 3.Then loose the model weight with the tag "mass". 4.If step 3 doesn't work fine, try to reduce the force param on wheel with tag "mu1 mu2 kd". 5.The final step is to increase the torque in controler plugin.

The following values can be used: robot body: mass = 20 wheel : mu1=1 mu2=1 kd=100

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-12-01 10:06:01 -0500

Seen: 743 times

Last updated: Mar 18 '19