Ask Your Question
0

ROS port roslaunch (IMU) problem /dev/ttyUSB0 to /dev/ttyACM0 ?

asked 2018-11-26 12:30:05 -0500

lucasvia gravatar image

Hi,

I am new to ROS but i am trying to observe my IMU system it's a 9dof razor IMU SEN 140001. I followed this tutorial : http://wiki.ros.org/razor_imu_9dof I have actually a problem who's that everytime i do this command :

roslaunch razor_imu_9dof razor-pub-and-display.launch

I got my * /imu_node/port: /dev/ttyUSB0 into my parameters however i would like it to be ttyACM0

I tried a lot of things, my_razor.yaml is already like this :

## USB port
port: /dev/ttyACM0

Also my .launch code is this one :

<launch>
  <arg name="razor_config_file" default="$(find razor_imu_9dof)/config/my_razor.yaml"/>
  <node pkg="razor_imu_9dof" type="imu_node.py" name="imu_node" output="screen">
    <rosparam file="$(arg razor_config_file)" command="load"/>
  </node>
  <node pkg="razor_imu_9dof" type="display_3D_visualization.py" name="display_3D_visualization_node" output="screen">
  </node>
</launch>

I have also tried to go in the imu_node to modify the port but it didn't change anything. And to use the command : rosparam set imu_node/port /dev/ttyACM0 but it didn't worked. I feel like everytime i roslaunch whatever I do it set the port to USB0

Could someone help ? I tried a lot of things i saw on Internet so I am finally posting here. Thank you for your help.

edit retag flag offensive close merge delete

Comments

Can you run this launch file and output everything ROS outputs during startup (parametars, nodes) ? Also please check if the paths are correct as you are probably using this which has some launch examples but is also missing a my_razor.yaml file.

Dyson sphere gravatar image Dyson sphere  ( 2018-12-26 22:59:42 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-12-26 23:20:43 -0500

pavankumarbn gravatar image

updated 2019-01-17 18:01:45 -0500

jayess gravatar image

Install minicom

$ sudo apt-get install minicom

After installation, Use this

$ sudo minicom -s

It will give a list, in that select Serial port setup. Here add Serial device information (in your case ttyACM0) and save the configuration. It will work. All the best!

edit flag offensive delete link more
0

answered 2018-12-26 19:35:38 -0500

terminal gravatar image

You can try to solve it with this website:http://www.corvin.cn/428.html

edit flag offensive delete link more

Comments

Please don't post link-only answers. If the website goes away then this answer will be of no help.

jayess gravatar image jayess  ( 2018-12-26 21:12:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-11-26 12:30:05 -0500

Seen: 973 times

Last updated: Jan 17 '19