ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

ASSERTION FAILED robot_localization error [closed]

asked 2018-11-21 22:15:27 -0600

PG_GrantDare gravatar image

Hi everyone. I am trying to run the package robot_localization however when I use my launch file it gives me this error;

[FATAL] [1542859479.759800234]: ASSERTION FAILED
file = /home/pg/ugv01_ws/src/maps_nav/robot_localization/src/ros_filter.cpp
line = 2313
cond = topicConfig.getType() == XmlRpc::XmlRpcValue::TypeArray

[FATAL] [1542859479.769316425]: ASSERTION FAILED
file = /home/pg/ugv01_ws/src/maps_nav/robot_localization/src/ros_filter.cpp
line = 2313
cond = topicConfig.getType() == XmlRpc::XmlRpcValue::TypeArray

[localisation/ekf_cont-2] process has died [pid 12445, exit code -5, cmd /home/pg/ugv01_ws/devel/lib/robot_localization/ekf_localization_node __name:=ekf_cont __log:=/home/pg/.ros/log/e35b3192-ee06-11e8-8312-78d00423a161/localisation-ekf_cont-2.log].
log file: /home/pg/.ros/log/e35b3192-ee06-11e8-8312-78d00423a161/localisation-ekf_cont-2*.log
 [localisation/ekf_disc-3] process has died [pid 12447, exit code -5, cmd /home/pg/ugv01_ws/devel/lib/robot_localization/ekf_localization_node odometry/filtered:=odometry/filtered_disc __name:=ekf_disc __log:=/home/pg/.ros/log/e35b3192-ee06-11e8-8312-78d00423a161/localisation-ekf_disc-3.log].
log file: /home/pg/.ros/log/e35b3192-ee06-11e8-8312-78d00423a161/localisation-ekf_disc-3*.log

Please help me to understand why this error is occurring and what steps I can take to resolve the issue?

Thank you in advance

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by PG_GrantDare
close date 2019-04-17 17:08:20.750328


For anyone stumbling along this, I have NO IDEA what I did to fix it. I restarted and ran catkin_make a few more times and it worked? If anyone does have an answer I would love that incase it happens again.

PG_GrantDare gravatar image PG_GrantDare  ( 2018-11-22 00:03:06 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-11-26 04:14:18 -0600

Tom Moore gravatar image

This usually indicates that your sensor configuration (the boolean array) was not formatted properly.

edit flag offensive delete link more


Thanks Tom, I did check over my config again and it worked.

PG_GrantDare gravatar image PG_GrantDare  ( 2018-12-02 23:35:02 -0600 )edit

Question Tools



Asked: 2018-11-21 22:15:27 -0600

Seen: 221 times

Last updated: Nov 26 '18