asus xtion pro live working with visp_auto_tracker

asked 2018-11-21 20:44:54 -0600

_suresh gravatar image

updated 2018-11-21 20:48:55 -0600

hi, not sure if this query has been answered before (please redirect me if it is), but i want to use Asus xtion pro live with visp_auto_tracker to make use of ar markers. i have used the asus xtion with openni2 and it seems to work, i can view all the topic and the images. however if i try to launch the auto_tracker launch file i get the

error : Cannot identify '/dev/video0': 2, No such file or directory

which i realize i am missing upon connecting the web cam . however i am able to view the usb device if i use lsusb

lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 001 Device 009: ID 1d27:0601 ASUS

Bus 001 Device 003: ID 413c:301a Dell Computer Corp.

Bus 001 Device 002: ID 413c:2113 Dell Computer Corp.

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

therefore i tried changing the device folder from /dev/video0 to /dev/bus/usb/001/009 (after looking at the lsusb) then i am getting some other error

VIDIOC_QUERYCAP error 25, Inappropriate ioctl for device

i am unable to find any other solution for this error. from my understanding the web cam is compatible since i am able to use openni2 to launch it but for some reason visp_auto_tracker will have some problem recognizing it . i have tried usb_cam package and it is giving me the same error . so i am not sure if i need to install some other packages or if this web cam not at all compatible with ros. if there are any solutions to this please help . thank you

some other info :

package visp_auto_tracker launch file: tracklive_usb.launch

ls -al /dev/video ---> ls: cannot access '/dev/video': No such file or directory

using ubuntu 16.04

using ROS kinetic

edit retag flag offensive close merge delete