Problem with costmap when using mbf_costmap_nav pkg of move_base_flex [closed]

asked 2018-11-09 02:52:06 -0500

Fan gravatar image

updated 2018-11-09 06:28:19 -0500

Hello everyone,

I want to do some tests with move_base pkg and move_base_flex pkg, so I tried first with move_base, no problem at all. And then, with all the same configurations (like configuration for global and local costmap ect), I tried mbf_costmap_nav package, somehow I got several problems, the robot is not at the center of the local costmap anymore.

I tried to modifed some configurations but it doesn't work, finally I added a local_costmap_params.yaml and loaded it in the move_base_flex.launch file, at this time the robot is at the center of the local costmap, but other problems are still there. When I send a move_base_flex/move_base/goal, I got all these:

[ WARN] [1541755691.675555499, 82.320000000]: MessageFilter [target=odom laser ]: Dropped 100.00% of messages so far. Please turn the [ros.costmap_2d.message_notifier] rosconsole logger to DEBUG for more information.
[ WARN] [1541697395.339270717, 223.300000000]: The robot's start position is off the global costmap. Planning will always fail, are you sure the robot has been properly localized?
[ WARN] [1541697395.342515415, 223.300000000]: MSG to TF: Quaternion Not Properly Normalized
[ WARN] [1541697522.159419983, 28.100000000]: Costmap2DROS transform timeout. Current time: 28.1000, global_pose stamp: 27.4900, tolerance: 0.5000
Could not get robot pose, cancelling reconfiguration
[ERROR] [1541700210.791474751, 1448.260000000]: ERROR: failed to set start state

My robot couldn't move, even though I re-send a goal manually, it doesn't work:

[ INFO] [1541700210.791507768, 1448.260000000]: [sbpl_lattice_planner] getting start point (0.0182941,-0.012466) goal point (1,1)

I set the action server as: /move_base_flex/move_base, then I send goal using mbf_msgs::MoveBaseGoal mbf_goal.

In fact, I am working on ROSPlan, I tired move_base with rosplan_interface_movebase, it works well. I created an rosplan_interface_movebaseflex, it's similar to rosplan_interface_movebase, just changing the action server name and the goal message type. I think there is no problem with my rosplan interface, just the problem using the mbf_costmap_nav package.

Can anyone help?

Thanks at advance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Fan
close date 2018-11-15 06:54:26.299937

Comments

If someone have the same problem, you can find answers here :

https://github.com/magazino/move_base...

Fan gravatar imageFan ( 2018-11-15 06:53:59 -0500 )edit