DWA planner fails to get path after switching from source install to binary

asked 2018-11-07 09:29:27 -0600

Matt_S gravatar image

updated 2018-11-07 11:26:53 -0600

gvdhoorn gravatar image

I wanted to edit the map_server for use with cartographer so I installed from source. After I did, Navigation ran horribly so I removed it and tried to switch back to using the binary installation. Since I'm using cartographer with Kinetic I am using ninja to make my project. I removed all install folders and re-built, but still no good. The DWA planner is not even moving the robot at all. If I bring navigation back in from source, it works, but again it has poor performance compared to the binary install. Am I missing steps somewhere?

This is my current output from nav.

[ INFO] [1541431084.895501853, 23.761000000]: Got new plan
[ WARN] [1541431084.915186353, 23.780000000]: DWA planner failed to produce path.
[ INFO] [1541431085.000501373, 23.862000000]: Got new plan
[ WARN] [1541431085.028524730, 23.888000000]: DWA planner failed to produce path.
[ INFO] [1541431085.103385883, 23.961000000]: Got new plan
[ WARN] [1541431085.124919847, 23.982000000]: DWA planner failed to produce path.
[ INFO] [1541431085.210148758, 24.061000000]: Got new plan
[ WARN] [1541431085.235411133, 24.086000000]: DWA planner failed to produce path.
edit retag flag offensive close merge delete

Comments

Not an actual solution, but are you setting Release mode build for navigation? Without that Debug will be selected which will reduce performance.

gvdhoorn gravatar imagegvdhoorn ( 2018-11-07 11:27:27 -0600 )edit

I am not. When I use the kinetic-devel branch of navigation, I just install and use directly. The problem I get is that my scan observation buffer performance gets very bad (Update warnings vary from .15 to 5 seconds, and I have expected_update_rate set to 0.1)

Matt_S gravatar imageMatt_S ( 2018-11-07 11:31:45 -0600 )edit

Then I would suggest to try building with CMAKE_BUILD_TYPE=RelWithDebInfo.

gvdhoorn gravatar imagegvdhoorn ( 2018-11-07 13:04:31 -0600 )edit

I tried with -DCMAKE_BUILD_TYPE=Release but it didn't do anything. I will try with the suggested command.

Matt_S gravatar imageMatt_S ( 2018-11-08 08:46:58 -0600 )edit

Hmm, with the command you gave me, It doesn't build. I am using ninja, so my full command is catkin_make_isolated CMAKE_BUILD_TYPE=RelWithDebInfo --install --use-ninja I tried catkin_make_isolated -DCMAKE_BUILD_TYPE=RelWithDebInfo --install --use-ninja and it still doesn't help.

Matt_S gravatar imageMatt_S ( 2018-11-08 08:50:08 -0600 )edit

If your workspace is already built, you'll need to remove the devel and build folders as the build tool will typically not rerun for just a CMAKE_BUILD_TYPE change.

But as I wrote earlier: none of this is an actual answer.

gvdhoorn gravatar imagegvdhoorn ( 2018-11-08 09:03:47 -0600 )edit

Indeed, I'd still like to find out why the binary install breaks after installing from source.

Matt_S gravatar imageMatt_S ( 2018-11-08 09:14:17 -0600 )edit

If you can provide a little more details as to how you "installed from source", "removed it" and "tried to switch back to using the binary installation" perhaps that can be answered.

Also: there is no need to use ninja or catkin_make_isolated: just use an underlay workspace for Cartographer.

gvdhoorn gravatar imagegvdhoorn ( 2018-11-08 09:15:24 -0600 )edit