Problems with turtlebot on Ubuntu 18.04 with melodic morenia

asked 2018-10-29 12:45:06 -0600

Silvia gravatar image

updated 2018-11-06 05:22:40 -0600

gvdhoorn gravatar image

I have Ubuntu 18.04 and I installed melodic morenia (ROS) but I saw that I'm not able to use turtlebot. So I tried to use a Docker container with a ros indigo image but when I try to download packages with this command sudo apt-get install ros-indigo-turtlebot-gazebo, I have a lot of problems and packages are not installed! Someone could help me?


Edit: I'm so sorry but I'm new with this type of questions here. I tried to install ros kinetic directly on Ubuntu 16.04 without Docker and now it's all ok. But I have another problem: I have Ubuntu 18.04 again and I'm not able to run sudo rosdep init . The errore is: sudo: rosdep: command not found.

I installed ros with this command:

sudo apt install ros-melodic-desktop-full

but now the error is:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-melodic-desktop-full : Depends: ros-melodic-desktop but it is not going to be installed
                            Depends: ros-melodic-perception but it is not going to be installed
                            Depends: ros-melodic-simulators but it is not going to be installed
                            Depends: ros-melodic-urdf-sim-tutorial but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried to solve the problem with this command:

SUDO APT-GET INSTALL APTITUDE
SUDO APTITUDE ROS-MELODIC-DESKTOP-FULL

and the result was:

The following NEW packages will be installed:
  fltk1.3-doc{a} fluid{a} gir1.2-gtk-2.0{a} google-mock{a} googletest{a} 
  hddtemp{a} libapr1-dev{a} libaprutil1-dev{a} libassimp-dev{a} 
  libassimp4{a} libassuan-dev{a} libatk1.0-dev{a} libbz2-dev{a} 
  libcairo-script-interpreter2{a} libcairo2-dev{a} libcharls1{a} 
  libconsole-bridge-dev{a} libconsole-bridge0.4{a} libdc1394-22-dev{a} 
  libexif-dev{a} libexif-doc{a} libfltk-cairo1.3{a} libfltk-forms1.3{a} 
  libfltk-gl1.3{a} libfltk-images1.3{a} libfltk1.3{a} libfltk1.3-dev{a} 
  libgdcm2-dev{a} libgdcm2.8{a} libgdk-pixbuf2.0-dev{a} libgpg-error-dev{a} 
  libgpgme-dev{ab} libgphoto2-dev{a} libgtest-dev{a} libgtk2.0-dev{a} 
  libilmbase-dev{a} libjs-jquery-ui{a} liblept5{a} liblog4cxx-dev{a} 
  liblog4cxx10v5{a} liblz4-dev{a} libopencv-calib3d-dev{a} 
  libopencv-calib3d3.2{a} libopencv-contrib-dev{a} libopencv-contrib3.2{a} 
  libopencv-core-dev{a} libopencv-core3.2{a} libopencv-dev{a} 
  libopencv-features2d-dev{a} libopencv-features2d3.2{a} 
  libopencv-flann-dev{a} libopencv-flann3.2{a} libopencv-highgui-dev{a} 
  libopencv-highgui3.2{a} libopencv-imgcodecs-dev{a} 
  libopencv-imgcodecs3.2{a} libopencv-imgproc-dev{a} 
  libopencv-imgproc3.2{a} libopencv-ml-dev{a} libopencv-ml3.2{a} 
  libopencv-objdetect-dev{a} libopencv-objdetect3.2{a} 
  libopencv-photo-dev{a} libopencv-photo3.2{a} libopencv-shape-dev{a} 
  libopencv-shape3.2{a} libopencv-stitching-dev{a} 
  libopencv-stitching3.2{a} libopencv-superres-dev{a} 
  libopencv-superres3.2{a} libopencv-ts-dev{a} libopencv-video-dev{a} 
  libopencv-video3.2{a} libopencv-videoio-dev{a} libopencv-videoio3.2{a} 
  libopencv-videostab-dev{a} libopencv-videostab3.2{a} libopencv-viz-dev{a} 
  libopencv-viz3.2{a} libopencv3.2-java{a} libopencv3.2-jni{a} 
  libopenexr-dev{a} libpango1.0-dev{ab} libpixman-1-dev{a} libpoco-dev{a} 
  libpococrypto50{a} libpocodata50{a} libpocodatamysql50{a} 
  libpocodataodbc50{a} libpocodatasqlite50{a ...
(more)
edit retag flag offensive close merge delete

Comments

1

I have a lot of problems

that's not nice, but it's also not nice that you don't provide us with any details / error messages or other information that we'd need to help you.

gvdhoorn gravatar imagegvdhoorn ( 2018-10-29 12:51:44 -0600 )edit

Have you tried that doing 'apt purge' all melodic and reinstall?

FrozenCh gravatar imageFrozenCh ( 2018-11-06 21:18:47 -0600 )edit

Yes I tried :( I'm sorry for the delay in my replay.

Silvia gravatar imageSilvia ( 2018-11-16 11:47:58 -0600 )edit