Ask Your Question
1

Can't find package spawn_robot_tools_pkg

asked 2018-10-17 09:16:19 -0600

kkelchte gravatar image

I'm following this tutorial on Wam-V RobotX challenge with ros-openai using ROS kinetic on ubuntu 16.

I installed packages openai_ros wamv_description robotx_gazebo and the packages within openai_examples_projects.

I can launch the simulator: roslaunch robotx_gazebo sandisland.launch (although the ocean model and sandisland are missing)

If I however test the training script: roslaunch turtle2_openai_ros_example start_training_maze.launch

It can't find spawn_robot_tools_pkg. I can't find this package in the apt list nor on ROS in general. How do I install this package?

A similar problem occured with the gym_construct package on the turtlebot2 tutorial.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-10-17 09:18:54 -0600

kkelchte gravatar image

Ok, please ignore this stupid question. The necessary robot packages can be found here: https://bitbucket.org/account/user/th... Scrolling through the 3 pages made me found the gym_construct and spawn_robot_tools_pkg.

A link in the tutorial to these locations would be nice though.

edit flag offensive delete link more

Comments

Good suggestion about the tutorial. Let us work on that

R. Tellez gravatar imageR. Tellez ( 2018-10-24 00:24:48 -0600 )edit

Had the same issue. The tutorial should be updated to reflect that you need to download the package gym_construct and a link. Without this package the tutorial is incomplete and impossible to follow because you fail at the very first step running $ roslaunch gym_construct main.launch.

tropic gravatar imagetropic ( 2019-01-10 13:03:38 -0600 )edit
1

And maybe also add that people should run rosdep install for all the packages, else they might end up with many other errors for missing dependencies when launching.

tropic gravatar imagetropic ( 2019-01-10 13:27:54 -0600 )edit

It also fails at launching with the following error [rospack] Error: package 'hukoyo' not found due to a change in the kobuki_description urdf: model://hokuyo/... to package://hokuyo/.... I do not know if it is suppose to be fixed in the kinetic branch where package://gazebo_plugins is used?

tropic gravatar imagetropic ( 2019-01-10 14:12:20 -0600 )edit

Here is a direct link to the repository @kkelchte was talking about: link text Took me a while to find it so I thought I would save the next person some trouble.

kboyd gravatar imagekboyd ( 2019-11-16 15:16:11 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-17 09:16:19 -0600

Seen: 476 times

Last updated: Oct 17 '18