Ask Your Question
0

Ros-win ros-catkin-tools install fail

asked 2018-10-10 07:02:08 -0600

CsorvaGep gravatar image

Hi,

I've tried to install ros-win as described in here: https://ros-win.visualstudio.com/_git... At the last step the ros-catkin-tools installation is failed, but the ros-melodic-desktop seems to install correctly.

Here's the error message:

ERROR: The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Exception: The upgrade of ros-catkin-tools was NOT successful. Error while running 'C:\ProgramData\chocolatey\lib\ros-catkin-tools\tools\chocolateyinstall.ps1'. See log for details.

I checked the log, but there is no additional information regarding the problem, or I can't find it. The installation is quite straightforward so I don't know where did I miss anything.

Anyone can guess what I did wrong?

edit retag flag offensive close merge delete

Comments

Can you run choco upgrade ros-catkin-tools again and post the full console output? The package was just getting updated and the version of 0.0.1.1810092059 comes with some fixes for this symptom. Maybe you can give it try?

Sean Yen gravatar imageSean Yen ( 2018-10-10 13:23:08 -0600 )edit

I've installed on a different computer and it worked now. It is maybe because of the new version, I'll check is tomorrow.

CsorvaGep gravatar imageCsorvaGep ( 2018-10-10 14:54:05 -0600 )edit

Glad to hear it worked now! :)

Sean Yen gravatar imageSean Yen ( 2018-10-10 15:14:36 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-11-13 12:34:45 -0600

You should: - remove all related ROS files in Chocolatey lib folder. In windows: C:/Programdata/chocolatey/lib. - remove the content of opt folder. - upgrade the package in chocolatey again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-10-10 07:02:08 -0600

Seen: 849 times

Last updated: Oct 10 '18