Ask Your Question
1

Segmentation fault installing Kinetic on Raspbian Stretch

asked 2018-10-08 12:44:58 -0600

danzimmerman gravatar image

updated 2018-10-08 12:49:28 -0600

I'm trying to follow instructions here http://wiki.ros.org/ROSberryPi/Instal... to install ROS Kinetic on my Raspberry Pi 3B.

I made some progress previously early last week, and this didn't happen. Many packages were successfully built, but the build failed while trying to build pluginlib. I decided to try again, did some apt-get updates in the meantime.

Now when I try to follow the instructions again, even after completely deleting the catkin workspace folder and making a new one, I get this right away:

~~  - rostopic
~~  - roswtf
~~  - topic_tools
~~  - rosbag
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
The packages or cmake arguments have changed, forcing cmake invocation

==> Processing catkin package: 'catkin'
==> Creating build directory: 'build_isolated/catkin'
==> cmake /home/computername/ros_catkin_ws/src/catkin -DCATKIN_DEVEL_PREFIX=/home/computername/ros_catkin_ws/devel_isolated/catkin -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -DCMAKE_BUILD_TYPE=Release -G Unix Makefiles in '/home/computername/ros_catkin_ws/build_isolated/catkin'
<== Failed to process package 'catkin':
  Command '['cmake', '/home/computername/ros_catkin_ws/src/catkin', '-DCATKIN_DEVEL_PREFIX=/home/computername/ros_catkin_ws/devel_isolated/catkin', '-DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status -11

Reproduce this error by running:
==> cd /home/computername/ros_catkin_ws/build_isolated/catkin && cmake /home/computername/ros_catkin_ws/src/catkin -DCATKIN_DEVEL_PREFIX=/home/computername/ros_catkin_ws/devel_isolated/catkin -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

Command failed, exiting.

Running the "reproduce this error" command just segfaults:

(cv) computername@computername:~/ros_catkin_ws $ cd /home/computername/ros_catkin_ws/build_isolated/catkin && cmake /home/computername/ros_catkin_ws/src/catkin -DCATKIN_DEVEL_PREFIX=/home/computername/ros_catkin_ws/devel_isolated/catkin -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'
Segmentation fault
(cv) computername@computername:~/ros_catkin_ws/build_isolated/catkin $

I've also tried this outside of the cv virtual environment with the same result.

I should probably just scrap the idea of doing it on Raspbian but there's significant config specific to my robot (GPIO dtoverlays, network and DNS config, etc) on my Raspbian install (backed up as well) and I don't want to start over right now. I think I had some kind of networking challenge with Ubuntu Mate that I don't want to tackle.

I might be able to re-set the state and get something else besides the segfault again by going back to an older backup disk image, but I'd also like to understand what is failing here if I can.

Any ideas where I can look? Anyone else having this problem?

edit retag flag offensive close merge delete

Comments

1

It seems cmake segfaults, so I would try and figure out why. Can you run cmake by itself (perhaps with some 'toy' project?

How did you install CMake on your system?

gvdhoorn gravatar imagegvdhoorn ( 2018-10-08 12:48:44 -0600 )edit

You're right, cmake just segfaults.

I tried this https://mirkokiefer.com/cmake-by-exam...

I installed with apt-get. I purged it and tried again with apt, following https://raspberrypi.stackexchange.com... , but same result.

danzimmerman gravatar imagedanzimmerman ( 2018-10-08 13:15:36 -0600 )edit
1

Then it would seem that would be the issue to diagnose. I expect things to start working again if/when you fix the CMake issue.

gvdhoorn gravatar imagegvdhoorn ( 2018-10-08 13:52:06 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-10-08 15:10:32 -0600

danzimmerman gravatar image

updated 2018-10-08 15:11:43 -0600

It seems like the prebuilt version of cmake I get on the Raspberry Pi with apt or apt-get is quite old, 3.7.something.

I built cmake 3.12.3 from source and that fixed it. I expect pluginlib build will still fail, but we'll deal with that later.

Thanks gvdhoorn.

edit flag offensive delete link more

Comments

It could be that the updates you performed to your OS before things failed introduced an ABI break. SEGFAULTs are common then.

It would surprise me though as Debian based OS typically guarantee and check ABI compatibility.

gvdhoorn gravatar imagegvdhoorn ( 2018-10-09 01:50:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-10-08 12:44:58 -0600

Seen: 96 times

Last updated: Oct 08 '18