Ask Your Question
0

colcon build ros1_bridge not producing executable

asked 2018-10-03 14:39:48 -0500

alsora gravatar image

updated 2018-10-04 18:55:44 -0500

UPDATE: my original question was about colcon build parameters, but thanks to the answer I discovered that the problem was not there. Hence I have adjusted a little bit the question for future reference.

Hi,

I'm basically following the ROS2 official documentation for installing from sources (reference here).

When I build the workspace using

colcon build

It looks like ros1_bridge executables are not installed.

If I source everything using

source install/setup.zsh

The output of ros2 pkg list shows ros1_bridge, but, checking ros2 pkg executables there are no executables.

I have the following directory

.ros2_ws/install/ros1_bridge
  |_ include
  |_ lib
     |_ libros1_bridge.so
     |_ python3.5
     |_ ros1_bridge
        |_ EXECUTABLES should be here but are not present.
  |_ share

Do you know why?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-10-04 12:30:49 -0500

nuclearsandwich gravatar image

Is it possible that when you built the workspace for the merged install directory the ROS 1 environment was not sourced?

For the ros1_bridge libraries and binaries to be built, there must be some ROS 1 libraries and messages available in the environment. There are instructions in the README: https://github.com/ros2/ros1_bridge#b...

I was able to reproduce the "missing" files in both merged and isolated install spaces and produce complete installations of the ros1_bridge in both when sourcing a ROS 1 workspace.

edit flag offensive delete link more

Comments

Thank you, I didn't noticed that part in the README and probably for some reason I had the ROS1 environment sourced when I compiled the first time.

alsora gravatar imagealsora ( 2018-10-04 13:14:46 -0500 )edit

@alsora do you mind updating your question title to be ros1_bridge specific. I think it has the potential to help others who encounter the same issue but the title won't be searchable for someone having issues with the ros1_bridge rather than with --merge-install.

nuclearsandwich gravatar imagenuclearsandwich ( 2018-10-04 18:31:08 -0500 )edit

Sure! I have also sent a PR to that repo, since using Colcon there was not even a warning message that something was missing... That's why I was searching the solution somewhere else rather than in the ros1_bridge docs

alsora gravatar imagealsora ( 2018-10-04 18:49:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-10-03 14:39:48 -0500

Seen: 316 times

Last updated: Oct 04 '18