Ask Your Question
1

Moveit benchmarking: cannot connect to warehouse database

asked 2018-09-30 09:45:40 -0500

ftre gravatar image

updated 2018-10-01 02:51:36 -0500

gvdhoorn gravatar image

Hello, I am just following this tutorial http://docs.ros.org/kinetic/api/movei... but after added the motion planning display in RViz I can't outcome the 2nd step : "Within the Motion Planning RViz plugin, connect to the database by pressing the Connect button in the Context tab.".

Shell says this : ros.warehouse_ros_mongo: Unable to connect to the database at '127.0.0.1:33829'. If you just created the database, it could take a while for initial setup.

I have sourced my workspace folder, and its src folder contains moveit built from source, as well as moveit_tutorials, panda_moveit_config, warehouse_ros, and warehouse_ros_mongo package folders.

Also where should I search for the source code which is called when the user clicks on "connect" within RViz ? In RViz files or in Moveit ones?

regards

edit retag flag offensive close merge delete

Comments

Can you please show us the exact commands you used to start things?

The database is only started if you enable it db:=true.

gvdhoorn gravatar image gvdhoorn  ( 2018-10-01 02:52:09 -0500 )edit

Indeed I used the one provided : roslaunch panda_moveit_config demo.launch db:=true

ftre gravatar image ftre  ( 2018-10-01 04:36:45 -0500 )edit

I am facing the same issue. Have you found the solution?

boon gravatar image boon  ( 2018-11-21 05:51:02 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-11-21 06:09:54 -0500

boon gravatar image

updated 2018-11-21 06:10:37 -0500

I had the same issue, i tried to install mongodb store

sudo apt-get install ros-kinetic-mongodb-store

and the problem solved.

Now, when I launch I get a different error.
2018-11-21T17:31:45.031+0530 Assertion: 17234:backgroundJob already running: PeriodicTaskRunner
2018-11-21T17:31:45.033+0530 0x7f13243e5b89 0x7f13243e773e 0x7f13243dd259 0x7f13243dd30c 0x7f13243e1090 0x7f13243e1515 0x7f13243aeaf4 0x7f1324362d7b 0x7f132436716a 0x7f13270f01b6 0x7f13270ec96b 0x7f13270e8e1e 0x7f13270e2d86 0x7f13270de47e 0x7f13270d7e97 0x7f13301e2a5f 0x7f13307469a8 0x7f13ab0825d5 0x7f13aae5b6ba 0x7f13aba3841d 
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros_mongo.so(_ZN5mongo15printStackTraceERSo+0x39) [0x7f13243e5b89]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros_mongo.so(_ZN5mongo10logContextEPKc+0x22e) [0x7f13243e773e]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros_mongo.so(_ZN5mongo11msgassertedEiPKc+0xd9) [0x7f13243dd259]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros_mongo.so(+0x11f30c) [0x7f13243dd30c]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros_mongo.so(_ZN5mongo13BackgroundJob2goEv+0x490) [0x7f13243e1090]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros_mongo.so(_ZN5mongo12PeriodicTask25startRunningPeriodicTasksEv+0x95) [0x7f13243e1515]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros_mongo.so(_ZN5mongo6client10initializeEb+0x124) [0x7f13243aeaf4]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros_mongo.so(_ZN19warehouse_ros_mongo23MongoDatabaseConnectionC2Ev+0xad) [0x7f1324362d7b]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros_mongo.so(_ZNK12class_loader20class_loader_private10MetaObjectIN19warehouse_ros_mongo23MongoDatabaseConnectionEN13warehouse_ros18DatabaseConnectionEE6createEv+0x24) [0x7f132436716a]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros.so(_ZN12class_loader20class_loader_private14createInstanceIN13warehouse_ros18DatabaseConnectionEEEPT_RKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEPNS_11ClassLoaderE+0x14c) [0x7f13270f01b6]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros.so(_ZN12class_loader11ClassLoader17createRawInstanceIN13warehouse_ros18DatabaseConnectionEEEPT_RKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEb+0xc3) [0x7f13270ec96b]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros.so(_ZN12class_loader11ClassLoader23createUnmanagedInstanceIN13warehouse_ros18DatabaseConnectionEEEPT_RKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x28) [0x7f13270e8e1e]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros.so(_ZN12class_loader23MultiLibraryClassLoader23createUnmanagedInstanceIN13warehouse_ros18DatabaseConnectionEEEPT_RKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0xae) [0x7f13270e2d86]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros.so(_ZN9pluginlib11ClassLoaderIN13warehouse_ros18DatabaseConnectionEE23createUnmanagedInstanceERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x5b8) [0x7f13270de47e]
 /home/dyana/catkin_make/devel/lib/libwarehouse_ros.so(_ZN13warehouse_ros14DatabaseLoader12loadDatabaseEv+0x2d1) [0x7f13270d7e97]
 /home/dyana/catkin_ws/devel/.private/moveit_ros_warehouse/lib/libmoveit_warehouse.so.0.10.5(_ZN16moveit_warehouse12loadDatabaseEv+0x2f) [0x7f13301e2a5f]
 /home/dyana/catkin_ws/devel/.private/moveit_ros_planning_interface/lib/libmoveit_move_group_interface.so.0.10.5(_ZN6moveit18planning_interface18MoveGroupInterface22MoveGroupInterfaceImpl34initializeConstraintsStorageThreadERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEj+0x38) [0x7f13307469a8]
 /usr/lib/x86_64-linux-gnu/libboost_thread.so.1.58.0(+0x115d5) [0x7f13ab0825d5]
 /lib/x86_64-linux-gnu/libpthread.so.0(+0x76ba) [0x7f13aae5b6ba]
 /lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x7f13aba3841d]
[ERROR] [1542801705.034086280]: backgroundJob already running: PeriodicTaskRunner
edit flag offensive delete link more

Comments

I´m facing the same problem, even though the package is already installed.

CharlieMAC gravatar image CharlieMAC  ( 2019-01-02 02:18:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-09-30 09:45:40 -0500

Seen: 568 times

Last updated: Nov 21 '18