Ask Your Question
0

How do I get the Robotiq force-torque sensor to work with ROS Kinetic?

asked 2018-09-25 15:55:20 -0600

mosslab gravatar image

Our lab is using Kinetic on Ubuntu 16.04 and we can't connect to our FT300 sensor with ROS. Using just the instructions in the FT300 manual (under the Development Package section), I was able to get sensor readings to show up in the terminal, so I do at least know my computer can make the connection. But rosrun robotiq_force_torque_sensor rq_sensor, which should do the same thing, just gives me lines and lines of "Waiting for sensor connection..." indefinitely. I've tried the following in various combinations:

  • Using both the jade-devel and kinetic-devel branches of the Robotiq repository
  • Specifying the exact \dev\ttyUSB* device that the sensor shows up as
  • Modifying my files using TheDash's pull request that allows FT300 support

Unfortunately I lack the technical knowledge to know what the source of this problem is. As far as I can tell, the only fix is to downgrade to Ubuntu 14.04 and Indigo, since another lab has been able to get their FT300 working that way. Has anyone else run into this problem and managed to solve it somehow? Otherwise, can anyone give me a rough idea of how much headway has been made towards making this possible?

Thanks for reading.

edit retag flag offensive close merge delete

Comments

If you're referring to ros-industrial/robotiq, then I would suggest posting an issue on the tracker, as Kinetic is supposed to be supported with the latest PRs merged.

gvdhoorn gravatar imagegvdhoorn ( 2018-09-26 09:15:22 -0600 )edit

Does FT300 Sensor connected to your own PC or does it connected to a central pc, like UR5 Robot pcs?

Meric gravatar imageMeric ( 2019-04-24 12:32:14 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-09-28 10:07:24 -0600

mosslab gravatar image

This problem was solved here: https://askubuntu.com/questions/11256...

Unfortunately the chosen answer at that link is not what solved it--I already added myself to dialout, but running sudo chown [me] /dev/ttyUSB1 allowed me to connect to the sensor. As it looks like I will have to run this every time I plug the sensor in, I'm going to look into some of the other answers in that thread.

edit flag offensive delete link more

Comments

@mosslab I am having the very same issue. I have added myself to the dialout and created a udev rules file but nothing has changed. Did you ever get to the bottom of this?

Thanks, Dom.

Edit: After a day of trying to work out why this was not working, I finally decided to simply turn off the Robotiq force/torque sensor and turn it back on again. It is now communicating with ROS.

(it's always something stupid!)

porkPy gravatar imageporkPy ( 2018-12-19 07:46:13 -0600 )edit

Does FT300 Sensor connected to your own PC or does it connected to a central pc, like UR5 Robot pcs?

Meric gravatar imageMeric ( 2019-04-24 12:31:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-09-25 15:54:30 -0600

Seen: 346 times

Last updated: Sep 28 '18