JointStateController does not post on /joint_states topic

asked 2018-09-19 09:31:30 -0600

RicPale gravatar image

updated 2018-09-21 03:32:39 -0600

Hi, I was following the ros tutorial on how to use urdf in gazebo with ros:

http://wiki.ros.org/urdf/Tutorials/Us...

However, when I start roslaunch urdf_sim_tutorial 09-joints.launch as described in the tutorial I get this message:

rostopic echo /joint_states
WARNING: no messages received and simulated time is active.

I have Ubuntu 16.4 and ros kinetik. Do you have any Idea, what causes this problem?

I really can't figure it out. Thank you so much in advance!

edit retag flag offensive close merge delete

Comments

The JointPositionController is not supposed to broadcast robot state, only the JointStateController does that.

Can you check your config and make sure the correct controller is loaded?

gvdhoorn gravatar imagegvdhoorn ( 2018-09-19 14:27:52 -0600 )edit

Hello gvdhoorn, thank you for your very quick answer! I misspelled in the headline. Thank you for pointing that out. I meant to write JointStateController, but I use the JointStateController in my yaml file:

type: "joint_state_controller/JointStateController" publish_rate: 30

RicPale gravatar imageRicPale ( 2018-09-21 03:35:33 -0600 )edit

also gazebo starts to crash sometimes, when I load the yaml file

RicPale gravatar imageRicPale ( 2018-09-21 06:58:06 -0600 )edit