Ask Your Question
1

USB_CAM error : Input/output error [closed]

asked 2018-09-09 00:16:04 -0500

takijo gravatar image

Hi,

I want to use web-camera(Logicool Webcam C210)

I use usb-cam package,but I cannnot see the web-camera view.

My launch file is below,

<launch>
  <node name="usb_cam" pkg="usb_cam" type="usb_cam_node" output="screen" >
    <param name="video_device" value="/dev/video0" />
    <param name="image_width" value="640" />
    <param name="image_height" value="480" />
    <param name="pixel_format" value="yuyv" />
    <param name="camera_frame_id" value="usb_cam" />
    <param name="framerate" value="30" />
    <param name="io_method" value="mmap"/>
  </node>
  <node name="image_view" pkg="image_view" type="image_view" respawn="false" output="screen">
    <remap from="image" to="/usb_cam/image_raw"/>
    <param name="autosize" value="true" />
  </node>
</launch>

So,I got the error messages

[ERROR] [1536468451.681312829]: VIDIOC_S_FMT error 5, Input/output error
[usb_cam-2] process has died [pid 4954, exit code 1, cmd /opt/ros/kinetic/lib/usb_cam/usb_cam_node __name:=usb_cam __log:=/home/username/.ros/log/729b5ef0-b3eb-11e8-a98a-a44e31601874/usb_cam-2.log].
log file: /home/username/.ros/log/729b5ef0-b3eb-11e8-a98a-a44e31601874/usb_cam-2*.log

I have checked my device by command:

v4l2-ctl --list-formats-ext

I confirmed device number ,view size and pixel_format.

I tried other web-camera(logicool C270), but I got same error messages.

So, What am I wrong?

thanks.

(I use Ubuntu16.04LTS,ros-kinetic,and I installed [v4l-utils] and [usb-cam] packages)

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by takijo
close date 2021-01-26 17:44:22.023528

Comments

I have the same issue, someone please suggest different solution

kiya gravatar image kiya  ( 2019-02-07 11:09:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-09-14 22:28:21 -0500

takijo gravatar image

I can solve this error by update ROS.

sudo apt-get update
sudo apt-get dist-upgrade

Thanks for your help.

edit flag offensive delete link more

Comments

1

This didn't work for me, can you suggest any other solution?

kiya gravatar image kiya  ( 2019-02-07 11:08:36 -0500 )edit

Please up your code and error message. and, make sure your cam device number ,view size and pixel_format match the code again.

takijo gravatar image takijo  ( 2019-02-07 15:27:49 -0500 )edit

Hello, I have the same problem, do you solve it?

nana gravatar image nana  ( 2019-04-15 07:03:17 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2018-09-09 00:16:04 -0500

Seen: 2,113 times

Last updated: Sep 14 '18