Ask Your Question
1

RVIZ- For frame [base_laser_link]: Fixed Frame [map] does not exist

asked 2018-09-08 02:05:10 -0600

naveenk.medi gravatar image

updated 2018-09-08 02:05:54 -0600

I've been going through Laser Scan Data tutorial.

I ran the command $rosbag play Mapping1.bag. I could see the /base_scan among the rostopic list and echo it to the console. But I am unable to view it on rviz.

I ran $rosrun rviz rviz and added display /base_scan/LaserScan.

RVIZ is showing Global status warning Fixed Frame - No tf data. Actual error: Fixed Frame [map] does not exist and status error For frame [base_laser_link]: Fixed Frame [map] does not exist. How can I fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-09-08 10:03:52 -0600

pcoenen gravatar image

The robot system has no transform data between the map frame and your robot frames. You would need some form of odometry or a transform publisher to see your laser scans in the map frame.

To find out which frame your scan is published in, have a look at the frame_id in your /base_scan message. The message is probably too long or fast to see the header data inside your terminal, so pipe it to less:

rostopic echo /base_scan | less

Based on your status error I'm guessing the frame_id is base_laser_link. To view your laser scan change the RViz Fixed Frame to that (or any frame connected to it in the tf tree).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-09-08 02:05:10 -0600

Seen: 1,720 times

Last updated: Sep 08 '18