Ask Your Question
0

Roscore and Sensors node are not starting on boot [Clearpath Husky]

asked 2018-08-29 23:15:49 -0500

Hello, I have recently got a husky from clearpath. When I boot the system the general behavior was to launch all the rosnodes on boot. I added my own laser scanner, and wanted to add it to the upstart menu. I used the robot_upstart package. But after adding my laser scanner launch file. On the next boot none of the nodes are starting. Is there a way to fix this issue.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-30 00:34:31 -0500

I removed all the job from /lib/systemd/systemd by using rosrun robot_upstart uninstall job_name and then augmented all the launch file to one master job file using:

 rosrun robot_upstart install my_custom_package/launch --job job_name --augment
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-29 23:15:49 -0500

Seen: 200 times

Last updated: Aug 30 '18