IK fast for 5 dof robot issue, openrave not showing the model

asked 2018-08-29 07:38:46 -0500

akosodry gravatar image

Hello ROS Community.

I have a 5DOF custom made robotic arm. I have been doing some cartesian path-based motion planning tasks with moveit commander, but (as it was expected) the default KDL fails to find solution quite often. Therefore, i tried to create the IKfast solver to my robot following the step-by-step instructions on the tutorial page.

I was able to successfully install the OpenSceneGraph, the FCL as well as the OpenRAVE based on the recommended link.

The first issue i encounter is, that the openrave "$MYROBOT_NAME".dae doesnt show the robot model. (the collada file was successfully created, and the openrave-robot.py "$MYROBOT_NAME".dae --info links shows the correct links, parents though).

This is the screenshot.

I tested the official UR5 description (e.g., i created the collada from the official ur5_robot.urdf.xacro), but the outcome was the same, the openrave doesnt show the robot, just some unrecognizable shapes, as on the previous screenshot.

What could be the problem here?

Nonetheless, i could generate the solution CPP File, but now with the IKFastKinematicsPlugin NO successful motion planning can be performed (10/10 times it fails to find solution for the tested reachable poses).

can i suspect, that the root of this problem is related to the wrongly displayed model in openrave?

I also tried to make a wrapper.xml as it was recommended here, but i did not change the outcome.

Thank you for the help in advance.

Best regards, Ákos

edit retag flag offensive close merge delete

Comments

I have a same problem. I find my robot model link is in a wrong place on OpenRave 0.9.0(Development Version) after i open "$MYROBOT_NAME".dae. Is the fault from the wrong software version or my urdf model or even the urdf cenvention?

shupianbanjia gravatar image shupianbanjia  ( 2018-10-28 06:11:47 -0500 )edit

Facing the same issue here as well. Somebody with a better understanding please help!

pendragon gravatar image pendragon  ( 2019-01-07 15:06:29 -0500 )edit

Did anyone manage to solve it yet?

Machine-Jonte gravatar image Machine-Jonte  ( 2020-05-09 05:31:44 -0500 )edit