Ask Your Question
0

I have problem regarding the KUKA_experimental installation.

asked 2018-08-27 11:47:32 -0500

MTV1368 gravatar image

updated 2018-08-27 12:03:00 -0500

Hello everyone, I tried to install KUKA manipulators within ROS-Industrial. I followed the following procedure :

  1. mkdir -p ~/moveit_ws_2/src --> cd /path/to/catkin_ws/src
  2. git clone https://github.com/ros-industrial/kuk... --> cd ..
  3. rosdep install --from-paths src --ignore-src
  4. catkin_make

PS I also did source the work space by : echo 'source ~/ws_moveit/devel/setup.bash' >> ~/.bashrc

However by putting this command roslaunch kuka_experimental kuka_rsi_simulator.launch I dumped to the following error:

[kuka_rsi_simulator.launch] is neither a launch file in package [kuka_experimental] nor is [kuka_experimental] a launch file name
The traceback for the exception was written to the log file

Could anyone please kindly help me ?

edit retag flag offensive close merge delete

Comments

1

It looks like there are multiple mistakes in the commands you listed. In (1) did you really run cd /path/to/catkin_ws/src or did you cd to ~/moveit_ws_2/src? Are you sourcing the setup.bash for ~/ws_moveit or ~/moveit_ws_2? What are your ROS environment variables (env |grep ROS)?

jarvisschultz gravatar image jarvisschultz  ( 2018-08-27 12:06:02 -0500 )edit

Most often the error that you are describing comes from people improperly sourcing the correct setup.bash file

jarvisschultz gravatar image jarvisschultz  ( 2018-08-27 12:07:07 -0500 )edit

Sorry for the typo. I did work in ~/moveit_ws/src . I followed the exact same way I have been asked on wiki.ros.org in the same order. I did source it right I am think as roscd works fine.

MTV1368 gravatar image MTV1368  ( 2018-08-27 14:27:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-08-27 12:05:04 -0500

gvdhoorn gravatar image

updated 2018-08-27 12:07:36 -0500

I also did source the work space by : echo 'source ~/ws_moveit/devel/setup.bash' >> ~/.bashrc

That doesn't source the workspace.

Or at least: it will source the workspace only after you start a new bash shell, or after you source $HOME/.bashrc.

Also: the workspace you created was named moveit_ws_2, not ws_moveit.

However by putting this command roslaunch kuka_experimental kuka_rsi_simulator.launch I dumped to the following error:

[kuka_rsi_simulator.launch] is neither a launch file in package [kuka_experimental] nor is [kuka_experimental] a launch file name

And this makes sense, as kuka_experimental is a metapackage, it doesn't contain any launch files.

If you want to start the kuka_rsi_simulator.launch launch file, the command would be:

roslaunch kuka_rsi_simulator kuka_rsi_simulator.launch
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-08-27 11:47:32 -0500

Seen: 56 times

Last updated: Aug 27 '18