Ask Your Question
0

Ubuntu 18.04 ROS Qt Creator Plug-in

asked 2018-08-23 13:47:23 -0500

Avner gravatar image

updated 2018-08-24 18:33:29 -0500

Hi

Is there a ROS Qt Creator plug-in for Ubuntu 18.04?

The latest I see is a plug-in for Ubunut 16.04 (in here)

Thanks, Avner


Edit: @fergs, thanks for the reply

I followed the installation instructions in here with qt-creator-opensource-linux-x86_64-4.7.0.run. I have the following environment:

Ubuntu 18.04 bionic - x86_64  
qtcreator version - Qt Creator 4.7.0 based on Qt 5.11.1

I first completed all the instructions, and then tried debugging a running ROS application. I followed the instructions in "1.8 Debug Catkin Workspace" (both by debugging a single file, and Attach to a running process) without success.

Among the steps I also completed "1.1.3 Setup Ubuntu to allow debugging/ptrace" (note that I did not have a file /etc/rc.local so I created an empty one with the following content) and rebooted.

#!/bin/sh -e
echo 0 | tee /proc/sys/kernel/yama/ptrace_scope
exit 0

But I'm getting an error message:

ptrace: Operation not permitted.
Could not attach to the process. Make sure no other debugger traces this process.
If your uid matches the uid
of the target process, check the settings of
/proc/sys/kernel/yama/ptrace_scope
For more details, see /etc/sysctl.d/10-ptrace.conf

EDIT:

After succeeding to build the project within qtc and after setting LD_LIBRARY_PATH in the Build Environment and doing another reboot, I can now run the program from qtc. In other terminals (outside of qtc), I run roscore, and rosviz and I can see the results from the node that is being run within qtc in e.g. rviz


I also tried building the project from qtc but I'm getting errors. The build error message is:

15:27:04: Running steps for project catkin_ws...
15:27:04: Could not start process "catkin_make -DCMAKE_BUILD_TYPE=Debug00" 
Error while building/deploying project catkin_ws (kit: Desktop)
When executing step "Custom Process Step"

EDIT:

I was able to build the project from qtc. I had to split the build command:

Command:
catkin_make

Arguments:
-DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_CXX_STANDARD=14

It would be useful to have a step after "1.6 Setup Build Settings for Catkin Workspace" to verify that a ROS project from qtc builds successfully before moving on.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-23 15:45:59 -0500

fergs gravatar image

It hasn't been released as a Debian yet for 18.04, but you can use the manual installation instructions here: https://github.com/Levi-Armstrong/ros...

edit flag offensive delete link more

Comments

Thanks, after following the installation instructions and applying some corrections to my settings (as described in the EDITS in my original question) I can build and run a ROS node using qtc and see the results from the node in an external ROS node (e.g. rviz)

Avner gravatar image Avner  ( 2018-08-24 18:35:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-23 13:47:23 -0500

Seen: 2,230 times

Last updated: Aug 24 '18