Navigation stack not working properly when running remotely

asked 2018-08-17 08:58:34 -0600

kuka_kuka gravatar image

updated 2018-08-20 04:38:28 -0600

Hi comunity!

When I execute "move_base" node in the local machine (the robot) I do not get any errors or warnings. But, when I run that node remotely (from my PC), after getting the message "odom received!", I get persistently the same warnings:

[ WARN] [1534427628.512533003]: Costmap2DROS transform timeout. Current time: 1534427628.5125, global_pose stamp: 1534427628.2315, tolerance: 0.2000
Could not get robot pose, cancelling reconfiguration

In both cases the configuration files used are the same. My PC and the robot clocks are synchronized using ntp. Any idea what can be happening? Would increasing the tolerance be a good idea for solving the problem? Thanks in advance.

Pd.: The reason why I want to execute it remotely is because the CPU consumption of the robot is over 100% and I believe that is the reason why when setting a navigation goal it gets lost...And it says: "Control loop missed its desired rate of 10.0000hz navigation... the loop actually took X.XXX seconds". Amcl works fine, so I do not think localization is the problem.

edit retag flag offensive close merge delete

Comments

What is your network latency? Did you measure network utilization? e.g. with wifi the latency can get really high (more then 200ms)

Humpelstilzchen gravatar imageHumpelstilzchen ( 2018-08-21 01:19:44 -0600 )edit

Latency is not high, I ping robot from my PC and mostly I get a latency of 1.5-5 ms and sometimes 30-50 ms. I can "solve" this problem by increasing "transform_tolerance" parameter in the "costmap_common_params.yaml" file from 0.2 to 0.5 but then I get the warning:

kuka_kuka gravatar imagekuka_kuka ( 2018-08-21 05:29:10 -0600 )edit

...: "The /base_scan observation buffer has not been updated for XX.XX seconds, and it should be updated every 0.20 seconds.". I can "solve" this increasing "expected_update_rate" from 0.2 to 1. After that I almost do not get this two warnings, but when setting a navigation goal robot only rotates.

kuka_kuka gravatar imagekuka_kuka ( 2018-08-21 05:31:56 -0600 )edit