Ask Your Question
0

hz of our sensor's the topic was DECREASED, When I record some data with rosbag. [closed]

asked 2018-08-14 03:29:07 -0500

Hello, experts.
I used rosbag to acquire our sensor data as camera, lidar.
You can reference below spec.

Camera Node : 1980x1208 (FHD, RGB), 20 hz
Lidar Node : 64 Channel, 20 hz

I recorded topics on pc using rosbag, but there is a decreasing.
// command $ rosbag record camera_topoic lidar_points_topic
When I check on another pc, their spec are blew.

Camera Node: 20 hz -> 5~6 hz Lidar Node: 20 hz -> 8~10 hz

I don't know where it depend on which problem. How can I debug this problem? Is there a general information which is good for this problem.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by harderthan
close date 2018-08-21 00:31:54.981099

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-08-14 04:59:47 -0500

If you're maxing out any of the resources of your computer then you would expect the message rate to decrease when you add more load on top. Have you tried running rqt_top to measure how much CPU and memory each of your nodes are using?

If you are indeed maxing out your computer you could try recording the rosbag on another computer or connecting the sensors to two different computers to spread the load. Although in this case you want to be careful you don't max out your network bandwidth.

edit flag offensive delete link more

Comments

1

Hello, @PeteBlackerThe3rd .
Thanks for your answer.

The problem was the network bandwidth.
rqt_top is a very useful package for me.
Thanks again.

harderthan gravatar image harderthan  ( 2018-08-20 08:36:58 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2018-08-14 03:29:07 -0500

Seen: 115 times

Last updated: Aug 14 '18