Ask Your Question
0

roscd can't find packages

asked 2018-08-13 12:42:55 -0600

kesuke gravatar image

updated 2018-08-20 02:02:41 -0600

hi ,

i'm using ros indigo and suddenly after reboot my pc i can't run some package , for example when i try to type :

"roscd turtle " and use the tab touch keyboard it gives only these packages

 turtle_actionlib/        turtlebot_description/   turtle_tf/
turtlebot_capabilities/  turtlesim/               turtle_tf2/

so why it can't detect turtlbot_teleop and other packages ?

edit retag flag offensive close merge delete

Comments

i had a problem with ubuntu so i dit réinstall it and everything worls fine

kesuke gravatar imagekesuke ( 2018-08-20 02:03:23 -0600 )edit

Have you tried rospack find turtlebot_teleop ? If rospack can't find it, then it must've been deleted if you did a apt-get autoremove.

ashwath1993 gravatar imageashwath1993 ( 2018-08-20 02:29:39 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-08-20 12:35:21 -0600

totalnewbie gravatar image

Have you tried sourcing the setup file again? This must be done for every fresh console. Do cd ~/path/to/your/catkin_workspace source devel/setup.bash

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-13 12:42:55 -0600

Seen: 161 times

Last updated: Aug 20 '18