Ask Your Question
0

Running a raspberry pi(wiring pi) node with roslaunch

asked 2018-08-04 14:00:53 -0600

Prof. xavier gravatar image

I am having trouble to run a node present in /ros_workspace/devel/lib/blink where blink is the package and this directory contains the blink executable, this executable is ran with root permission, I dont understand the work around with roslaunch with such files.

How can I run this with one roslaunch with other nodes in the bot.

Please let me know any other info that maybe needed to solve this. thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-04 16:14:08 -0600

dan gravatar image

Did you source the workspace?

Normally, the source call is made in ~/.bashrc, but you can also just use it from the command line.

For ROS kinetic:

source /opt/ros/kinetic/setup.bash

and, in your case, assuming that your catkin workspace is actually ~/ros_workspace:

source ~/ros_workspace/devel/setup.bash

Then you should be able to do

roslaunch blink blink
edit flag offensive delete link more

Comments

how can I make the launch automatically ask for root access and automatically run as root, as wiringpi cpp requires root access.

Prof. xavier gravatar imageProf. xavier ( 2018-08-05 13:20:02 -0600 )edit

That's a common problem with wiringpi and ROS. You will have to go through the hassle of setting permissions on /dev/mem and /dev/gpiomem. I suggest considering alternatives like pigpio or RPi.gpio where the permissions are already setup.

dan gravatar imagedan ( 2018-08-06 01:57:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-08-04 14:00:53 -0600

Seen: 344 times

Last updated: Aug 04 '18