"timeout expired" error on tb3 bringup

asked 2018-08-03 12:12:17 -0500

AmateurHour gravatar image

updated 2018-08-05 07:38:39 -0500

We are attempting to run multiple bots from one rosmaster, and as a result we are trying to use namespaces along with tf_prefixes. We recently updated our OpenCR firmware to 1.2.2 to accommodate this. However, when we follow the Robotis turtlebot3 e-manual on loading multiple turtlebots , we get the error Failed to get param: timeout expired about our tf_prefix when we run the robot bringup launch file.The result is that none of our transforms get prefixes. Also, strangely enough, it sometimes works. Any ideas how to fix this so that it works every time? Thank you!

edit retag flag offensive close merge delete

Comments

we encounter same problem, but we manage to solve it by comment out the time out protection in the node_handle cpp file

slbpex895 gravatar imageslbpex895 ( 2018-08-08 01:41:58 -0500 )edit

Hi, I encounter same problem, can I know how to edit the node_handle cpp file? bool requestParam(const char * name, int time_out = 1000) <- here? or other things?

tabtabt gravatar imagetabtabt ( 2018-10-27 05:12:33 -0500 )edit

I had the same issue on TB3 burger, everytime run up the below launch on TB3, such warning will happen. Maybe it is not a big deal? Anyone managed out the solution??

macleonsh gravatar imagemacleonsh ( 2019-05-07 01:16:46 -0500 )edit

I am having this exact issue as well! It's preventing me from running the navigation stack as I can't transform the robot's frame to map frame. I tried messing with the node_handle cpp file by making the time out longer, but it still doesn't work. Any suggestions?

lemon123 gravatar imagelemon123 ( 2019-07-30 14:52:43 -0500 )edit