Raspberry Pie crash during catkin_make

asked 2018-08-01 04:50:53 -0600

firuze gravatar image

updated 2018-08-24 09:15:00 -0600

Hello! I am new at ROS and after cloning hector_slam package I wanted to catkin_make. It crashes and stops working and I have to unplug the pasberry pie to start over. At my last attempt, after reading similar problems and solutions on this website I tried the command "catkin_make -j1" and it continued until 90%. I alread use kinetic distro. I would be most grateful if you can help me to solve this problem!

edit retag flag offensive close merge delete

Comments

1

There is no attached file. Please copy-paste the console text directly into your question.

As to your problem: make sure to have swap enabled.

Finally: make sure you actually have to compile things from source. If you run Ubuntu or Debian, there is a chance you can install using apt-get.

gvdhoorn gravatar imagegvdhoorn ( 2018-08-01 04:56:42 -0600 )edit

since the raspberry crashes, it is not possible to use copy paste. I am trying to upload the pciture here but it doesn´t work. I both tried png and jpeg file, should I try with another format?

firuze gravatar imagefiruze ( 2018-08-01 05:42:39 -0600 )edit

@firuze you can't upload an image because you don't have enough karma. Can you run the command from an ssh session and copy and paste the output?

jayess gravatar imagejayess ( 2018-08-01 05:46:24 -0600 )edit

The exact error message is not too important as long as it is either an OOM killer message, or something similar. Running everything in an SSH session should allow you to copy-paste it though.

In any case: make sure you have swap enabled.

gvdhoorn gravatar imagegvdhoorn ( 2018-08-02 02:55:29 -0600 )edit

I am not able to connect my raspberry pi with SSH session, that gives another pile of errors.. Still could not solve it but thanks for the answers.

firuze gravatar imagefiruze ( 2018-08-24 09:16:38 -0600 )edit

Have you checked whether swap is enabled?

gvdhoorn gravatar imagegvdhoorn ( 2018-08-24 09:25:28 -0600 )edit

@gvdhoorn and I have the exact same intuition here. If you are running into trouble, you can always add some swap if you have a spare USB. You can find some instructions for that here and probably many other places.

allenh1 gravatar imageallenh1 ( 2018-08-24 16:26:58 -0600 )edit