Ask Your Question
0

Problem with starting of room map construction process using Intel RealSense R200

asked 2018-07-26 07:41:21 -0500

johnsmith gravatar image

updated 2018-07-26 08:03:18 -0500

gvdhoorn gravatar image

Hello. I've got 3D camera Intel RealSense R200, but I haven't got TurtleBot. The operating system is Ubuntu 14.04.5 kernel 4.4.0-130-generic. ROS distro: Indigo. The following information was used for camera configuration and room map construction: http://wiki.ros.org/rtabmap_ros/Tutor... . http://wiki.ros.org/rtabmap_ros/Tutor... .

Starting procedure is the following:

roscore

export TURTLEBOT_3D_SENSOR=r200
roslaunch turtlebot_bringup minimal.launch
export TURTLEBOT_3D_SENSOR=r200
roslaunch rtabmap_ros demo_turtlebot_mapping.launch args:="--delete_db_on_start" rgbd_odometry:=true depth_topic:=/camera/depth_registered/sw_registered/image_rect_raw 
roslaunch rtabmap_ros demo_turtlebot_rviz.launch

Launch files log:

$ roslaunch  rtabmap_ros demo_turtlebot_mapping.launch args:="--delete_db_on_start" rgbd_odometry:=true depth_topic:=/camera/depth_registered/sw_registered/image_rect_raw 
... logging to /home/hulk/.ros/log/79eae048-8a58-11e8-818e-240a64bf4b09/roslaunch-hulk-X550CL-2002.log 
Checking log directory for disk usage. This may take awhile. 
Press Ctrl-C to interrupt 
Done checking log file disk usage. Usage is <1GB. 

started roslaunch server http://192.168.43.162:37408/ 

SUMMARY 
======== 

PARAMETERS 
 * /camera/camera_nodelet_manager/num_worker_threads: 4 
 * /camera/depth_rectify_depth/interpolation: 0 
 * /camera/disparity_depth/max_range: 4.0 
 * /camera/disparity_depth/min_range: 0.5 
 * /camera/disparity_registered_sw/max_range: 4.0 
 * /camera/disparity_registered_sw/min_range: 0.5 
 * /camera/driver/base_frame_id: camera_link 
 * /camera/driver/camera_type: R200 
 * /camera/driver/color_fps: 30 
 * /camera/driver/color_frame_id: camera_rgb_frame 
 * /camera/driver/color_height: 480 
 * /camera/driver/color_optical_frame_id: camera_rgb_optica... 
 * /camera/driver/color_width: 640 
 * /camera/driver/depth_fps: 30 
 * /camera/driver/depth_frame_id: camera_depth_frame 
 * /camera/driver/depth_height: 360 
 * /camera/driver/depth_optical_frame_id: camera_depth_opti... 
 * /camera/driver/depth_width: 480 
 * /camera/driver/enable_color: True 
 * /camera/driver/enable_depth: True 
 * /camera/driver/enable_fisheye: False 
 * /camera/driver/enable_imu: False 
 * /camera/driver/enable_ir2: True 
 * /camera/driver/enable_ir: True 
 * /camera/driver/enable_pointcloud: False 
 * /camera/driver/enable_tf: False 
 * /camera/driver/fisheye_frame_id: camera_fisheye_frame 
 * /camera/driver/fisheye_optical_frame_id: camera_fisheye_op... 
 * /camera/driver/imu_frame_id: camera_imu_frame 
 * /camera/driver/imu_optical_frame_id: camera_imu_optica... 
 * /camera/driver/ir2_frame_id: camera_ir2_frame 
 * /camera/driver/ir2_optical_frame_id: camera_ir2_optica... 
 * /camera/driver/ir_frame_id: camera_ir_frame 
 * /camera/driver/ir_optical_frame_id: camera_ir_optical... 
 * /camera/driver/mode: manual 
 * /camera/driver/serial_no: 
 * /camera/driver/usb_port_id: 
 * /camera/points_xyzrgb_sw_registered/queue_size: 100 
 * /depthimage_to_laserscan/output_frame_id: /camera_depth_frame 
 * /depthimage_to_laserscan/range_min: 0.45 
 * /depthimage_to_laserscan/scan_height: 10 
 * /move_base/DWAPlannerROS/acc_lim_theta: 2.0 
 * /move_base/DWAPlannerROS/acc_lim_x: 1.0 
 * /move_base/DWAPlannerROS/acc_lim_y: 0.0 
 * /move_base/DWAPlannerROS/forward_point_distance: 0.325 
 * /move_base/DWAPlannerROS/global_frame_id: odom 
 * /move_base/DWAPlannerROS/goal_distance_bias: 24.0 
 * /move_base/DWAPlannerROS/max_rot_vel: 5.0 
 * /move_base/DWAPlannerROS/max_scaling_factor: 0.2 
 * /move_base/DWAPlannerROS/max_trans_vel: 0.5 
 * /move_base/DWAPlannerROS/max_vel_x: 0.5 
 * /move_base/DWAPlannerROS/max_vel_y: 0.0 
 * /move_base/DWAPlannerROS/min_rot_vel: 0.4 
 * /move_base/DWAPlannerROS/min_trans_vel: 0.1 
 * /move_base/DWAPlannerROS/min_vel_x: 0.0 
 * /move_base/DWAPlannerROS/min_vel_y: 0.0 
 * /move_base/DWAPlannerROS/occdist_scale: 0.5 
 * /move_base/DWAPlannerROS/oscillation_reset_dist: 0.05 
 * /move_base/DWAPlannerROS/path_distance_bias: 64.0 
 * /move_base/DWAPlannerROS/publish_cost_grid_pc: True 
 * /move_base/DWAPlannerROS/publish_traj_pc: True 
 * /move_base/DWAPlannerROS/rot_stopped_vel: 0.4 
 * /move_base/DWAPlannerROS/scaling_speed: 0.25 
 * /move_base/DWAPlannerROS/sim_time: 1.0 
 * /move_base/DWAPlannerROS/stop_time_buffer: 0.2 
 * /move_base/DWAPlannerROS/trans_stopped_vel: 0.1 
 * /move_base/DWAPlannerROS/vtheta_samples: 20 
 * /move_base/DWAPlannerROS/vx_samples: 6 
 * /move_base/DWAPlannerROS/vy_samples: 1 
 * /move_base/DWAPlannerROS/xy_goal_tolerance: 0.15 
 * /move_base/DWAPlannerROS/yaw_goal_tolerance: 0.3 
 * /move_base/GlobalPlanner/allow_unknown: True 
 * /move_base/GlobalPlanner/cost_factor: 3.0 
 * /move_base/GlobalPlanner/default_tolerance: 0.0 
 * /move_base/GlobalPlanner/lethal_cost: 253 
 * /move_base/GlobalPlanner/neutral_cost: 50 
 * /move_base/GlobalPlanner/old_navfn_behavior: False 
 * /move_base/GlobalPlanner/planner_costmap_publish_frequency: 0.0 
 * /move_base/GlobalPlanner/planner_window_x: 0.0 
 * /move_base/GlobalPlanner/planner_window_y: 0.0 
 * /move_base/GlobalPlanner/publish_potential: True 
 * /move_base ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2018-08-01 16:03:07 -0500

matlabbe gravatar image

updated 2018-08-02 13:40:25 -0500

On rtabmap side, you may set subscribe_scan to false here to not subscribe to missing laser scan. Otherwise, to fix depthimage_to_laserscan, you may have to remap the name of the topic used by that nodelet here, by the depth image generated by the r200 (which may have different name than other 3d sensors like kinect/xtion).

EDIT

In turtlebot_bringup package, change these lines in 3dsensor.launch so that $(arg camera)/$(arg depth)/image_raw is $(arg camera)/$(arg depth)/sw_registered/image_rect_raw instead OR set depth_registration argument to false here.

The problem is that r200 launch file doesn't provide the hardware registered depth image /camera/depth_registered/image_raw, instead it provides only the software registered version /camera/depth_registered/sw_registered/image_rect_raw

Other option, I updated demo_turtlebot_mapping.launch to be able to use software registration, that way you don't have to change anything from turtlebot_bringup launch files. With this new launch file and r200:

export TURTLEBOT_3D_SENSOR=r200
roslaunch turtlebot_bringup minimal.launch
export TURTLEBOT_3D_SENSOR=r200
roslaunch rtabmap_ros demo_turtlebot_mapping.launch args:="--delete_db_on_start" rgbd_odometry:=true depth_topic:=/camera/depth_registered/sw_registered/image_rect_raw sw_registered:=true
roslaunch rtabmap_ros demo_turtlebot_rviz.launch
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-26 07:41:21 -0500

Seen: 129 times

Last updated: Aug 02 '18