Stuck at ROS Melodic Tutorial (Chapter 1.3)

asked 2018-07-26 03:29:10 -0500

Stoverflow gravatar image

Hello, I'm following the steps here to install ROS Melodic on Ubuntu 18.04. URL: http://wiki.ros.org/melodic/Installat...

I'm running a Windows 10 machine with the Windows Linux Subsystem activated (I do not want to resort to a virtual machine). At first, I downloaded and installed "Ubuntu" from the Microsoft Store and got stuck at Chapter 1.4. I then realize that the "Ubuntu" app is version 16.04 and so it wouldn't support ROS Melodic. I then uninstalled "Ubuntu", downloaded and installed "Ubuntu 18.04" from the Microsoft Store and created a new username. Now, I follow the steps again and this time I'm stuck even earlier - at Chapter 1.3.

The keyserver receive keeps failing, even after using the other two alternative hks sites. Basically, the reason given is: No dirmngr

I tried to install dirmngr and the console says it is already installed and is the newest version. Yet, the keyserver receive still failed. Take a look at the screenshot.

Console Screenshot

Apologies for any inconvenience or grievances caused.

edit retag flag offensive close merge delete

Comments

Here's the image link if it couldn't display properly: https://imgur.com/a/L0sRZmb

Stoverflow gravatar imageStoverflow ( 2018-07-26 03:29:54 -0500 )edit

There's a thread on github with other people who have had this problem with 18.04 on WSL. This post on that thread shows a potential workaround - might be worth giving it a shot.

stevejp gravatar imagestevejp ( 2018-07-26 07:20:16 -0500 )edit

Thanks Steve, that workaround worked. Installation is complete.

Stoverflow gravatar imageStoverflow ( 2018-07-31 21:55:27 -0500 )edit