LeddarVu8 through serial

asked 2018-07-24 06:48:57 -0500

Hypomania gravatar image


Ubuntu 16.04, Kinetic distro.

Has anyone ever managed to get LeddarVu8 working through serial on ROS? By serial I mean the USB cable. There is package for Leddar products https://github.com/mcgill-robotics/ros-leddar, but I can't get it working, keep getting LeddarConnect() LD_ERROR error message during roslaunch. As far as I know other people were having similar issues, I wonder if this can be somehow resolved?

Just to clarify, I know I can run it through CAN but I would very much prefer running it through serial, is that doable?

Any suggestions are greatly appreciated!

edit retag flag offensive close merge delete


Did you set up your udev rules?

stevemacenski gravatar image stevemacenski  ( 2018-07-24 19:27:45 -0500 )edit

@smac, I did, double checked them as well, my user is in the right group.

Hypomania gravatar image Hypomania  ( 2018-07-25 02:35:32 -0500 )edit

@Hypomania I got the same problem, have you solved it? by the way, demo in SDK3.2.0 doesn't work for me too.

pan gravatar image pan  ( 2018-07-29 20:55:43 -0500 )edit

@pan, I ended up using CAN, I think the new leddar vu8 is quite different from the older version so might have a few differences in its firmware.

Hypomania gravatar image Hypomania  ( 2018-07-30 02:14:01 -0500 )edit

@Hypomania Yes, I updated the firmware in windows after your reply, but it still doesn't work. Maybe you can teach me how to make it works through CAN. by the way, you can see my sensor picture here at the bottom.

pan gravatar image pan  ( 2018-07-30 06:34:01 -0500 )edit

@pan, CAN is pretty straight forward. You need a USB to CAN or PCIE CAN interface for your ROS host. Then just use this package here: https://github.com/dispatch-ai/ros-leddar-vu8. Don't forget to add a 100-120 ohm resistor across the CAN+ and CAN-

Hypomania gravatar image Hypomania  ( 2018-07-30 08:05:30 -0500 )edit

@Hypomania I got a USB to CAN device and connected it to leddarVu8 according to the document. My ubuntu16.04 can detect it when I use lsusb and dmesg order with sensor plugin in but no file under /dev/, what should I do next to make leddarVu8 work with it?

pan gravatar image pan  ( 2018-08-02 02:00:31 -0500 )edit

@pan, that's interesting, I just tested mine and it doesn't detect it either. Makes me think that you MUST install Kvaser drivers rather than using socetCAN, then redirect the stream from Kvaser drivers to the ROS node.

Hypomania gravatar image Hypomania  ( 2018-08-03 05:51:51 -0500 )edit