Ask Your Question
0

Can I use a package with a different distribution for which it was made?

asked 2018-07-23 09:16:26 -0600

Metalzero2 gravatar image

Hello all,

I want to use a realsense camera with ROS. The package for this can be found here. The problem/question I have is, can I use this with ROS melodic, even thought in the package page is says it was made for indigo and kinetic? To my understanding, if there have not been any huge changes between to different ROS distributions, the package should work properly with newer distributions. Additionally, I'm installing the package from source, so I thought it should work.

I followed the steps for the installation, found here. However, after I did, ROS does not see the package. I write "rosrun real" followed by a double tab, to show packages that start with this name, but nothing. I also wrote down the whole name, with no results.

Any sugestions/ideas? Am I just not installing from source the package correctly (I have limited experience with this)?

edit retag flag offensive close merge delete

Comments

If you have any errors please update your question with them

jayess gravatar imagejayess ( 2018-07-23 11:11:05 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-07-23 11:14:43 -0600

jayess gravatar image

updated 2018-07-23 11:15:43 -0600

Yes, you can use packages that were written for another distribution of ROS than the one that you're currently using. You will most likely need to download the source and compile it yourself vs using apt. Once you compile it, then source your setup.bash with

cd ~/catkin_ws
source devel/setup.bash

Note: you may run into issues using a package that's meant for one distribution of ROS on another, but you may not.

edit flag offensive delete link more

Comments

Hmm this is weird. I thought I tried this already. I attempted to do it again today and it worked. I guess after to much time working on it yesterday, I confused my self. In any case, thanks. It is up and running now.

Metalzero2 gravatar imageMetalzero2 ( 2018-07-24 06:31:45 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-23 09:16:26 -0600

Seen: 318 times

Last updated: Jul 23 '18