Ask Your Question
1

Problems with ur3 Simulation

asked 2018-07-20 04:42:46 -0500

Raffzy gravatar image

Hello,

Im pretty new to ros and im trying to get a simulation of a ur3 to work. Ive been following the instructions on the universal_robot Git but i seem to get multiple error messages.

When i clone the Git to my catkin workspace and run all the rosrun commands as instructed

roslaunch ur_description ur3_upload.launch 
roslaunch ur3_moveit_config ur3_moveit_planning_execution.launch sim:=true
roslaunch ur3_moveit_config moveit_rviz.launch config:=true

the messages i get are:

Skipping virtual joint 'fixed_base' because its child frame 'base_link' does not match the URDF frame 'world'

,

[ WARN] [1532077114.269386647]: Waiting for /follow_joint_trajectory to come up
[ WARN] [1532077120.271582767]: Waiting for /follow_joint_trajectory to come up
[ERROR] [1532077126.272691382]: Action client not connected: /follow_joint_trajectory

and in RViz i get

Global Status: Warn 
    No tf data. Actual error: Fixed Frame [world] does not exist

I could get rid of the first problem by following this suggestion but renaming all the "world" links doesn't get me any further in solving my "missing fixed world frame" problem. Any suggestions would be appreciated.

edit retag flag offensive close merge delete

Comments

1
roslaunch ur_description ur3_upload.launch

The readme in the repository you link does this:

roslaunch ur_gazebo ur3.launch

That is different from what you do. I would expect things to work if you run the command above.

gvdhoorn gravatar imagegvdhoorn ( 2018-07-20 07:44:51 -0500 )edit
1

Hi! Can you post the results of rosrun tf view_frames followed by an evince frames.pdf?

aaditya_saraiya gravatar imageaaditya_saraiya ( 2018-07-20 15:17:05 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-21 10:13:21 -0500

Raffzy gravatar image

Ok... turnes out i had a completely different problem.

I do everything on a Virtual Machine (VMware to be specific) and it seems like gazebo has a big issue with using the 3D accerlation setting in VM->settings->display.

Every time i ran

roslaunch ur_gazebo ur3.launch

the gezebo window popped up, couldn't see a robot but i didn't really connect the dots. Basically nothing but the gazebo window worked.

Because of that i got some "parameters missing" error message when i ran

roslaunch ur3_moveit_config ur3_moveit_planning_execution.launch sim:=true

and using

roslaunch ur_description ur3_upload.launch

seemed to "fix" that issue.

Well, now ive set up a completely new VM with Accerlation turned off and everything worked smoothly.

edit flag offensive delete link more

Comments

2

I do everything on a Virtual Machine

Without being overly dramatic, please always include such information in your question text. As you've noticed yourself, there was no way we were going to figure this out without knowing that you were using VMWare.

In the future, mention things like this.

gvdhoorn gravatar imagegvdhoorn ( 2018-07-21 10:29:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-20 04:42:46 -0500

Seen: 159 times

Last updated: Jul 21 '18